Closed Bug 1430493 Opened 5 years ago Closed 4 years ago

In reader view, latex formulas/equations are doubled (should remove items that have inline style="display: none")

Categories

(Toolkit :: Reader Mode, defect, P3)

57 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla62
Tracking Status
firefox62 --- fixed

People

(Reporter: amundvedal, Assigned: Gijs)

References

()

Details

(Whiteboard: [reader-mode-readability-algorithm])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20180103231032

Steps to reproduce:

Open a page containing Latex equation in Firefox Reader view:
https://en.wikipedia.org/wiki/Big-O_notation


Actual results:

Formulas get doubled in Reader view. 


Expected results:

Formulas should only show up once.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
20180114220708
Status: UNCONFIRMED → NEW
Has Regression Range: --- → irrelevant
Has STR: --- → yes
Component: Untriaged → Reader Mode
Ever confirmed: true
OS: Unspecified → All
Product: Firefox → Toolkit
Hardware: Unspecified → All
Priority: -- → P3
Summary: In reader view, latex formulas/equations are doubled → In reader view, latex formulas/equations are doubled (should remove items that have inline style="display: none")
Whiteboard: [reader-mode-readability-algorithm]
See Also: → 1466044
This is fixed in readability on github, I think (at least as summarized). Ni me to update the m-c version.
Flags: needinfo?(gijskruitbosch+bugs)
This was fixed by bug 1467742 and will ship as part of Firefox 62.
Assignee: nobody → gijskruitbosch+bugs
Blocks: 1467742
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(gijskruitbosch+bugs)
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
Duplicate of this bug: 1478548
You need to log in before you can comment on or make changes to this bug.