Closed Bug 1430516 Opened 2 years ago Closed 2 years ago

Cannot select cell by [Ctrl] + mouse left click after landing bug 1425440

Categories

(Core :: DOM: Core & HTML, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla59
Tracking Status
firefox-esr52 --- unaffected
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 - fixed

People

(Reporter: m_kato, Assigned: baku)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

This issue seems to be regression by bug 1425440.

- Step
1. Open data:text/html,<table border=1><tr><td>abc</td><td>def</td>
2. [Ctrl] + mouse left click "abc" cell in table

- Result
"abc" string is selected.  (abc's background is blue)

- Expected Result
Cell of "abc" is selected.  (table cell's border is blue).
:baku, this issue seems to be regression by bug 1425440 according to mozgression.  Before landing it, [Ctrl] + mouse click selects table cell, not string into cell.  But after landing it, it selects string into cell instead.   Is this expected change?
Flags: needinfo?(amarchesini)
[Tracking Requested - why for this release]:
This is regression by bug 1425440
Assignee: nobody → amarchesini
Flags: needinfo?(amarchesini)
Attached patch selection.patchSplinter Review
Before it was:

if ((endOffset - startOffset) != 1)

now it must be:

if (!child || child->GetNextSibling() != range->GetChildAtEndOffset()) {

but it was:

if (!child || child != range->GetChildAtEndOffset()) {
Attachment #8942648 - Flags: review?(catalin.badea392)
Priority: -- → P2
Attachment #8942648 - Flags: review?(catalin.badea392) → review+
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f4d2bd7f41da
Fixing a regression when a table cell is selected, r=catalinb
https://hg.mozilla.org/mozilla-central/rev/f4d2bd7f41da
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.