Korean characters look too thin compared to Latin letters

RESOLVED DUPLICATE of bug 1407869

Status

()

defect
RESOLVED DUPLICATE of bug 1407869
Last year
Last year

People

(Reporter: 5silentrain, Unassigned)

Tracking

57 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
20180103231032

The Wikipedia page looks the same as the Chrome rendering to me.

On that page, right-click the Korean text and choose Inspect Element. In the developer tools pane that opens, click the Fonts tab on the right side. What are all the fonts listed in that box?
Reporter

Comment 2

Last year
Georgia & Gulim.
That's the problem then.

1. Enter the following into the location bar:
about:config?filter=font.*.ko
2. If any preferences appear in bold text with the status "user set" right-click each one and choose Reset.
3. Open about:preferences.
4. In the search box, type font
5. In the search results, click the Advanced… button.
6. Choose Fonts for: Korean. You should see the settings at their defaults: Proportional: Sans Serif; Serif: Default; Sans-serif: Default (Malgun Gothic); Monospace: Default.
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Firefox: 57.0.4, Build ID: 20180103231032

@5silentrain thanks for reporting this!
I have manged to reproduce the issue on latest Firefox 57.0.4 release, but is not reproducible on latest Nightly (59.0a1) build.
On Firefox 57.0.4 the default fronts are Georgia & Gulim and on Nightly 59.0a1 the default fonts are: Georgia & Malgun Gothic. 

Considering this I have used mozregression tools in order to find when the issue was fixed. Here are the results:
First good revision: d10766b6ea6040f33c774a8087f36de0cc9d6074
Last bad revision: 7e391c3586f9a6b2e5496915c0c1357eb93e30ad
Pushlog: https://goo.gl/PncqBD

It seems that this issue was fixed by bug 1407869 and will lend in the next Firefox release.
Status: UNCONFIRMED → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1407869
You need to log in before you can comment on or make changes to this bug.