Closed Bug 1430599 Opened 2 years ago Closed 2 years ago

Massive Memory & CPU usage just doing repeated Bing.com searches

Categories

(Core :: General, defect)

58 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1420485

People

(Reporter: macmilln82, Unassigned)

Details

(Whiteboard: [MemShrink])

Attachments

(1 file)

Attached file memory-report.json.gz
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20180111124119

Steps to reproduce:

Just go to bing.com and do repeated searches.


Actual results:

As I perform each additional search, I watch my memory usage skyrocket (upwards of 2gb) and CPU spikes too.  Firefox noticeably slows as well.


Expected results:

I believe firefox should maintain speed and consistent memory doing something simple like a web search.
Product: Core → Firefox
Hey Eric, do you see anything suspicious in the attached memory log?
Flags: needinfo?(erahm)
Product: Firefox → Core
Whiteboard: [MemShrink]
(In reply to Panos Astithas [:past] (please ni?) from comment #1)
> Hey Eric, do you see anything suspicious in the attached memory log?

The overall memory usage in that report doesn't appear to be too high. Can we get a report when the memory usage spikes? I am seeing a ton of js zones, instead of one per script it's 5

Content Script jid1-OY8Xu5BsKZQa6A@jetpack
Content Script {446900e4-71c2-419f-a6a7-df9c091e268b}
Content Script uBlock0@raymondhill.net
Content Script mozilla_cc3@internetdownloadmanager.com

That's interesting but probably not that big of a deal.

We can see most of the memory is in css strings:

> 360.37 MB (100.0%) -- explicit
> ├──170.74 MB (47.38%) -- js-non-window
> │  ├──143.55 MB (39.83%) -- zones
> │  │  ├──109.68 MB (30.44%) -- zone(0x19a80479000)
> │  │  │  ├───63.83 MB (17.71%) -- strings
> │  │  │  │   ├───0.38 MB (00.11%) ++ string(<non-notable strings>)
> │  │  │  │   ├───0.13 MB (00.03%) ++ string(length=73092, copies=1, "data:text/css;charset=utf-8,COOKIE-ALERT%2C%0ACOOKIE-NOTICE%2C%0Acookie-permission%2C%0ACOOKIE-WARNING%2C%0Adiv%5Bdata-module%3D%22cookie_banner%22%5D%2C%0Adiv%5Belement-structure-cookiemonster%5D%2C%0AXK-COOKIE-POLICY-WARNING%2C%0Adiv%5Bid%3D%22__accept_cookie%22%5D%2C%0Adiv%5Bid%3D%22__ndcc_cookieImpliedConsent%22%5D%2C%0Adiv%5Bid%3D%22_cookieConsentWrapper%22%5D%2C%0Adiv%5Bid%3D%22_CookieText%22%5D%2C%0Adiv%5Bid%3D%22_iph_cp_popup%22%5D%2C%0Adiv%5Bid%5E%3D%22__ic-notice%22%5D%2C%0A%5Bhref%5E%3D%22http%3A%2F%2Fsmi2.net%2F%22%5D%2C%0Aembed%5Bsrc%3D%22http%3A%2F%2Fwww.xatech.com%2Fweb_gear%2Fchat%2Fchat.swf%22%5D%2C%0Aa%5Btitle%3D%22WhatsApp%20Newsletter%20Marketing%22%5D%2C%0A%5Bhref%5E%3D%22http%3A%2F%2Fclick.hotlog.ru%2F%22%5D%2C%0A%5Bhref%5E%3D%22http%3A%2F%2Fhitcounter.ru%2Ftop%2Fstat.php%22%5D%2C%0A%5Bhref%5E%3D%22http%3A%2F%2Fmetrika.yandex.ru%2Fstat%2F%22%5D%2C%0A%5Bhref%5E%3D%22http%3A%2F%2Ftop.mail.ru%2Fjump%22%5D%2C%0A%5Bhref%5E%3D%22http%3A%2F%2Ftop100.rambler.ru%2F%22%5D%2C%0A%5Bhref%5E%3D%22htt" (truncated))

This leads me to believe this is a dup of 1420485. We're trying to get that landed ASAP.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Flags: needinfo?(erahm)
Resolution: --- → DUPLICATE
Duplicate of bug: 1420485
You need to log in before you can comment on or make changes to this bug.