epa.gov - html parse may be incorrect

VERIFIED FIXED

Status

VERIFIED FIXED
17 years ago
4 years ago

People

(Reporter: burleigh, Assigned: bc)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.0+)
Gecko/20020507
BuildID:    2002050705

The page layout is totally broken but (ugh ;-) is ok in IE.

Reproducible: Always
Steps to Reproduce:
1. visit the site
2. view source


Actual Results:  obviously broken layout

One of my users testing RC1 sent this to me.  On first looking at view source I
believed that Moz should put up a messaging saying "this html sucks" or
something.  But then I noted the source looks intact using w3c's validator and
IE.  I wonder if the parsing breaks with <!link... tag?  Note how Moz' view
source shows no further <head> material and doesn't find the opening of the
layout <table>?

Comment 1

17 years ago
Strict doctype, might be Tech Evangelism issue.
Related: bug 133976, bug 126017.

Comment 2

17 years ago
looks fine without that doctype.

The stylesheet is being served with "Content-Type: application/x-pointplus",
which IIRC means we don't use it if in strict mode [must be text/css?] (although
I think that is wrong: i.e., "be strict in _sending_, be tolerant in _receiving_"]
Status: UNCONFIRMED → NEW
Ever confirmed: true
What John said... to evangelism.
Assignee: attinasi → bclary
Component: Layout → US Gov
OS: Windows XP → All
Product: Browser → Tech Evangelism
QA Contact: petersen → chrisn
Hardware: PC → All
Version: other → unspecified
(Assignee)

Updated

17 years ago
Summary: html parse may be incorrect → epa.gov - html parse may be incorrect
(Reporter)

Comment 4

17 years ago
bz: what happens with this sort of issue?  On the one hand it was obvious to me
that the page has issues.  But on the other hand, I'm concerned that View Source
presented a mangled depiction of the source while IE and the w3c validator
seemed to show the source text correctly.  Thanks.
*** Bug 146283 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
Looks like they fixed the css mime type. all the pages i've clicked through
looks fine now.
(Assignee)

Comment 7

17 years ago
yep -> fixed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 8

16 years ago
verified using 2003052623
Status: RESOLVED → VERIFIED
(Assignee)

Comment 9

16 years ago
tech evang june 2003 reorg
Component: US Gov → English US
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.