empty parameter resultItemStart in <interpret> cause html code to be partially displayed

RESOLVED EXPIRED

Status

RESOLVED EXPIRED
17 years ago
9 years ago

People

(Reporter: tom.lebr, Unassigned)

Tracking

({helpwanted})

Trunk
x86
Windows 2000
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
search plugin containing <interpret> tag with an empty parameter e.g. resultItemStart	= ''
displays in a browser window the filtered page with first <a href > tag visible
althought it should be interpreted as HTML

problem appears to be in nsInternetSearchService.cpp ,
InternetSearchDataSource::ParseHTML

5127 // if resultItemStartStr is not specified, try making it just be "HREF="
5128                 if (resultItemStartStr.IsEmpty())
5129                 {
5130                       resultItemStartStr.Assign(NS_LITERAL_STRING("HREF="));
5131                       trimItemStart = PR_FALSE;
5132                 }

resultItemStartStr points in the middle of tag, but should be moved slightly
backwards

an example of a plugin affected is
http://www.volny.cz/tomlebr/mozilla/search/Atlas0.src
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

17 years ago
Keywords: helpwanted
Target Milestone: --- → mozilla1.0.1

Updated

16 years ago
Depends on: 172120

Updated

16 years ago
Blocks: 172120
No longer depends on: 172120

Comment 1

15 years ago
retargeting
Target Milestone: mozilla1.0.1 → Future
(Assignee)

Updated

10 years ago
Product: Core → SeaMonkey
Assignee: samir_bugzilla → nobody
QA Contact: claudius → search
Target Milestone: Future → ---

Comment 2

10 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 3

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.