Status

()

defect
P3
normal
VERIFIED DUPLICATE of bug 14157
20 years ago
20 years ago

People

(Reporter: rginda, Assigned: troy)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

mContent->GetDocument(*getter_AddRefs(doc)); is returning a NULL doc, subsequent
operations on doc cause a crash.

(gdb) print doc
$2 = {mRawPtr = 0x0}

#0  0x40cb46e5 in nsTextFrame::Reflow (this=0x8ec2e58, aPresContext=@0x8a5c8f8,
aMetrics=@0xbfffa938, aReflowState=@0xbfffa978, aStatus=@0xbfffb3bc) at
nsTextFrame.cpp:2392
#1  0x40c9b2c7 in nsLineLayout::ReflowFrame (this=0xbfffb454, aFrame=0x8ec2e58,
aNextRCFrame=0xbfffab3c, aReflowStatus=@0xbfffb3bc) at nsLineLayout.cpp:904
#2  0x40c96c84 in nsInlineFrame::ReflowInlineFrame (this=0x8ece200,
aPresContext=0x8a5c8f8, aReflowState=@0xbfffabcc, irs=@0xbfffab3c,
aFrame=0x8ec2e58, aStatus=@0xbfffb3bc) at nsInlineFrame.cpp:1565
#3  0x40c9675e in nsInlineFrame::ReflowInlineFrames (this=0x8ece200,
aPresContext=0x8a5c8f8, aReflowState=@0xbfffabcc, irs=@0xbfffab3c,
aMetrics=@0xbfffab8c, aStatus=@0xbfffb3bc) at nsInlineFrame.cpp:1400
#4  0x40c964a0 in nsInlineFrame::Reflow (this=0x8ece200,
aPresContext=@0x8a5c8f8, aMetrics=@0xbfffab8c, aReflowState=@0xbfffabcc,
aStatus=@0xbfffb3bc) at nsInlineFrame.cpp:1316
#5  0x40c9b2c7 in nsLineLayout::ReflowFrame (this=0xbfffb454, aFrame=0x8ece200,
aNextRCFrame=0xbfffad90, aReflowStatus=@0xbfffb3bc) at nsLineLayout.cpp:904
#6  0x40c96c84 in nsInlineFrame::ReflowInlineFrame (this=0x8ec8828,
aPresContext=0x8a5c8f8, aReflowState=@0xbfffae20, irs=@0xbfffad90,
aFrame=0x8ece200, aStatus=@0xbfffb3bc) at nsInlineFrame.cpp:1565
#7  0x40c9675e in nsInlineFrame::ReflowInlineFrames (this=0x8ec8828,
aPresContext=0x8a5c8f8, aReflowState=@0xbfffae20, irs=@0xbfffad90,
aMetrics=@0xbfffade0, aStatus=@0xbfffb3bc) at nsInlineFrame.cpp:1400
#8  0x40c964a0 in nsInlineFrame::Reflow (this=0x8ec8828,
aPresContext=@0x8a5c8f8, aMetrics=@0xbfffade0, aReflowState=@0xbfffae20,
aStatus=@0xbfffb3bc) at nsInlineFrame.cpp:1316
#9  0x40c9b2c7 in nsLineLayout::ReflowFrame (this=0xbfffb454, aFrame=0x8ec8828,
aNextRCFrame=0xbfffafe4, aReflowStatus=@0xbfffb3bc) at nsLineLayout.cpp:904
#10 0x40c96c84 in nsInlineFrame::ReflowInlineFrame (this=0x8ec87e0,
aPresContext=0x8a5c8f8, aReflowState=@0xbfffb074, irs=@0xbfffafe4,
aFrame=0x8ec8828, aStatus=@0xbfffb3bc) at nsInlineFrame.cpp:1565
#11 0x40c9675e in nsInlineFrame::ReflowInlineFrames (this=0x8ec87e0,
aPresContext=0x8a5c8f8, aReflowState=@0xbfffb074, irs=@0xbfffafe4,
aMetrics=@0xbfffb034, aStatus=@0xbfffb3bc) at nsInlineFrame.cpp:1400
#12 0x40c964a0 in nsInlineFrame::Reflow (this=0x8ec87e0,
aPresContext=@0x8a5c8f8, aMetrics=@0xbfffb034, aReflowState=@0xbfffb074,
aStatus=@0xbfffb3bc) at nsInlineFrame.cpp:1316
#13 0x40c9b2c7 in nsLineLayout::ReflowFrame (this=0xbfffb454, aFrame=0x8ec87e0,
aNextRCFrame=0xbfffb238, aReflowStatus=@0xbfffb3bc) at nsLineLayout.cpp:904
#14 0x40c96c84 in nsInlineFrame::ReflowInlineFrame (this=0x8f033e8,
aPresContext=0x8a5c8f8, aReflowState=@0xbfffb2c8, irs=@0xbfffb238,
aFrame=0x8ec87e0, aStatus=@0xbfffb3bc) at nsInlineFrame.cpp:1565
#15 0x40c9675e in nsInlineFrame::ReflowInlineFrames (this=0x8f033e8,
aPresContext=0x8a5c8f8, aReflowState=@0xbfffb2c8, irs=@0xbfffb238,
aMetrics=@0xbfffb288, aStatus=@0xbfffb3bc) at nsInlineFrame.cpp:1400
#16 0x40c964a0 in nsInlineFrame::Reflow (this=0x8f033e8,
aPresContext=@0x8a5c8f8, aMetrics=@0xbfffb288, aReflowState=@0xbfffb2c8,
aStatus=@0xbfffb3bc) at nsInlineFrame.cpp:1316
#17 0x40c9b2c7 in nsLineLayout::ReflowFrame (this=0xbfffb454, aFrame=0x8f033e8,
aNextRCFrame=0xbfffbd84, aReflowStatus=@0xbfffb3bc) at nsLineLayout.cpp:904
#18 0x40c71195 in nsBlockFrame::ReflowInlineFrame (this=0x8be5898,
aState=@0xbfffbcfc, aLineLayout=@0xbfffb454, aLine=0x8f03430, aFrame=0x8f033e8,
aLineReflowStatus=0xbfffb40b "") at nsBlockFrame.cpp:3383
#19 0x40c70e6a in nsBlockFrame::DoReflowInlineFrames (this=0x8be5898,
aState=@0xbfffbcfc, aLineLayout=@0xbfffb454, aLine=0x8f03430,
aKeepReflowGoing=0xbfffbca4, aLineReflowStatus=0xbfffbbb3 "\002") at
nsBlockFrame.cpp:3274
#20 0x40c70c93 in nsBlockFrame::DoReflowInlineFramesAuto (this=0x8be5898,
aState=@0xbfffbcfc, aLine=0x8f03430, aKeepReflowGoing=0xbfffbca4,
aLineReflowStatus=0xbfffbbb3 "\002") at nsBlockFrame.cpp:3220
#21 0x40c70a86 in nsBlockFrame::ReflowInlineFrames (this=0x8be5898,
aState=@0xbfffbcfc, aLine=0x8f03430, aKeepReflowGoing=0xbfffbca4) at
nsBlockFrame.cpp:3169
#22 0x40c6f2d9 in nsBlockFrame::ReflowLine (this=0x8be5898, aState=@0xbfffbcfc,
aLine=0x8f03430, aKeepReflowGoing=0xbfffbca4, aDamageDirtyArea=1) at
nsBlockFrame.cpp:2429
#23 0x40c6ea0a in nsBlockFrame::ReflowDirtyLines (this=0x8be5898,
aState=@0xbfffbcfc) at nsBlockFrame.cpp:2178
#24 0x40c6d8b0 in nsBlockFrame::Reflow (this=0x8be5898, aPresContext=@0x8a5c8f8,
aMetrics=@0xbfffc044, aReflowState=@0xbfffbf64, aStatus=@0xbfffc258) at
nsBlockFrame.cpp:1417
#25 0x40c6ab04 in nsAreaFrame::Reflow (this=0x8be5898, aPresContext=@0x8a5c8f8,
aDesiredSize=@0xbfffc044, aReflowState=@0xbfffbf64, aStatus=@0xbfffc258) at
nsAreaFrame.cpp:401
#26 0x40c7a020 in nsContainerFrame::ReflowChild (this=0x8be5910,
aKidFrame=0x8be5898, aPresContext=@0x8a5c8f8, aDesiredSize=@0xbfffc044,
aReflowState=@0xbfffbf64, aStatus=@0xbfffc258) at nsContainerFrame.cpp:439
#27 0x40cac755 in nsScrollFrame::Reflow (this=0x8be5910,
aPresContext=@0x8a5c8f8, aDesiredSize=@0xbfffc25c, aReflowState=@0xbfffc110,
aStatus=@0xbfffc258) at nsScrollFrame.cpp:615
#28 0x40e2c0c3 in nsBoxFrame::FlowChildAt (this=0x8bf2580, childFrame=0x8be5910,
aPresContext=@0x8a5c8f8, desiredSize=@0xbfffc25c, aReflowState=@0xbfffc5cc,
aStatus=@0xbfffc258, aInfo=@0x8bf25c8, aRedraw=@0xbfffc254, aReason=@0xbfffc238)
at nsBoxFrame.cpp:1049
#29 0x40e2b091 in nsBoxFrame::GetChildBoxInfo (this=0x8bf2580,
aPresContext=@0x8a5c8f8, aReflowState=@0xbfffc5cc, aFrame=0x8be5910,
aSize=@0x8bf25c8) at nsBoxFrame.cpp:362
#30 0x40e2d1da in nsBoxFrame::GetBoxInfo (this=0x8bf2580,
aPresContext=@0x8a5c8f8, aReflowState=@0xbfffc5cc, aSize=@0x8be845c) at
nsBoxFrame.cpp:1475
#31 0x40e2aed7 in nsBoxFrame::GetChildBoxInfo (this=0x8be8348,
aPresContext=@0x8a5c8f8, aReflowState=@0xbfffc5cc, aFrame=0x8bf2580,
aSize=@0x8be845c) at nsBoxFrame.cpp:317
#32 0x40e2d1da in nsBoxFrame::GetBoxInfo (this=0x8be8348,
aPresContext=@0x8a5c8f8, aReflowState=@0xbfffc5cc, aSize=@0xbfffc4d4) at
nsBoxFrame.cpp:1475
#33 0x40e2b25a in nsBoxFrame::Reflow (this=0x8be8348, aPresContext=@0x8a5c8f8,
aDesiredSize=@0xbfffc66c, aReflowState=@0xbfffc5cc, aStatus=@0xbfffc854) at
nsBoxFrame.cpp:476
#34 0x40c7a020 in nsContainerFrame::ReflowChild (this=0x8bd3088,
aKidFrame=0x8be8348, aPresContext=@0x8a5c8f8, aDesiredSize=@0xbfffc66c,
aReflowState=@0xbfffc5cc, aStatus=@0xbfffc854) at nsContainerFrame.cpp:439
#35 0x40c8a9e4 in RootFrame::Reflow (this=0x8bd3088, aPresContext=@0x8a5c8f8,
aDesiredSize=@0xbfffc7c4, aReflowState=@0xbfffc71c, aStatus=@0xbfffc854) at
nsHTMLFrame.cpp:325
#36 0x40c7a020 in nsContainerFrame::ReflowChild (this=0x8b91028,
aKidFrame=0x8bd3088, aPresContext=@0x8a5c8f8, aDesiredSize=@0xbfffc7c4,
aReflowState=@0xbfffc71c, aStatus=@0xbfffc854) at nsContainerFrame.cpp:439
#37 0x40cb8619 in ViewportFrame::Reflow (this=0x8b91028,
aPresContext=@0x8a5c8f8, aDesiredSize=@0xbfffc974, aReflowState=@0xbfffc858,
aStatus=@0xbfffc854) at nsViewportFrame.cpp:514
#38 0x40c8be83 in nsHTMLReflowCommand::Dispatch (this=0x8eddb18,
aPresContext=@0x8a5c8f8, aDesiredSize=@0xbfffc974, aMaxSize=@0xbfffc95c,
aRendContext=@0x8edb318) at nsHTMLReflowCommand.cpp:137
#39 0x40ca66d6 in PresShell::ProcessReflowCommands (this=0x88d4c60) at
nsPresShell.cpp:1260
#40 0x40ca437b in PresShell::ExitReflowLock (this=0x88d4c60) at
nsPresShell.cpp:598
#41 0x40ca7d1c in PresShell::ContentAppended (this=0x88d4c60,
aDocument=0x89b1a08, aContainer=0x8bc5c1c, aNewIndexInContainer=0) at
nsPresShell.cpp:1690
#42 0x408eb831 in ?? () from
/home/rginda/src/mozilla_DEV/mozilla/dist/bin/components/librdf.so
#43 0x40cc39dd in nsGenericHTMLContainerElement::AppendChildTo (this=0x8bc5c24,
aKid=0x892843c, aNotify=1) at nsGenericHTMLElement.cpp:2824
#44 0x40cc2b84 in nsGenericHTMLContainerElement::InsertBefore (this=0x8bc5c24,
aNewChild=0x8928430, aRefChild=0x0, aReturn=0xbfffcb58) at
nsGenericHTMLElement.cpp:2481
#45 0x40cc32f0 in nsGenericHTMLContainerElement::AppendChild (this=0x8bc5c24,
aNewChild=0x8928430, aReturn=0xbfffcb58) at nsGenericHTMLElement.cpp:2667
#46 0x40cdce7a in nsHTMLDivElement::AppendChild (this=0x8bc5c10,
aOldChild=0x8928430, aReturn=0xbfffcb58) at nsHTMLDivElement.cpp:48
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
This is a DUP of an already fixed problem, but if it weren't I would mark it
INVALID because there's no URL or any way to reproduce the bug...

*** This bug has been marked as a duplicate of 14157 ***
Status: RESOLVED → VERIFIED
Marking as verified duplicate of 14157.
You need to log in before you can comment on or make changes to this bug.