Closed Bug 1430724 Opened 2 years ago Closed 2 years ago

Firefox hangs when closing tab with touch screen

Categories

(Core :: Widget: Win32, defect, P2)

All
Windows
defect

Tracking

()

RESOLVED DUPLICATE of bug 1446904
Tracking Status
firefox59 --- affected

People

(Reporter: franziskus, Unassigned)

Details

Attachments

(1 file)

Attached image windows-touch-bug.gif
When trying to close tabs via touch input Firefox hangs until it gets another input via mouse or keyboard. See attached screen capture.
Can you provide more specific steps to reproduce. I'm not able to trigger this based on what you've provided so far.
Flags: needinfo?(franziskuskiefer)
Steps to reproduce:
* open a couple tabs
* try to close them by tapping the X on a touch screen
Sometimes the first tab closes but at least starting with the second tab Firefox freezes completely until the mouse is moved. Going to the window overview is the only way to un-freeze Firefox in a touch-screen-only setting (swiping from the left side of the screen).
Maybe it also depends on the hardware? This is on a Surface Book 2nd gen with an up-to-date Windows 10.
Flags: needinfo?(franziskuskiefer)
OS: Unspecified → Windows
Priority: -- → P2
Hardware: Unspecified → All
same problem -> lenovo yoga 520, win 10, FF 58.0.2 64 bit
when opening a new tab(or link in new tab) with touchscreen, FF freezes for 10-20 seconds (1 in 10 cases) - could be unfrozen by movement on the touchpad
Same problem here. 

Windows 10 all updates.
Microsoft Surface Pro

Cleaned system and reinstalled Firefox, bug persists.

Firefox does not unfreeze until another touch on desktop or OS menus.
(In reply to Gord from comment #5)
> Same problem here. 
> 
> Windows 10 all updates.
> Microsoft Surface Pro
> 
> Cleaned system and reinstalled Firefox, bug persists.
> 
> Firefox does not unfreeze until another touch on desktop or OS menus.

To add: Other browsers and apps are fine.
i have same problem.
Reproduction condition:
Work offline, then hit CTRL+T for few seconds (Open approx 30-40tabs), then click x button with finger or stylus.
After closed several tabs, firefox suddenly no responding until move mouse, hit Windows key, etc.

PC Surface 4 pro (i5 6300U, 4GB RAM, 120GB SSD)
OS Windows 10 Pro (10.0.16299.334)
Both are same tablet mode on and off
Firefox Quantum (32bit) 59.0.2
Firefox Nightly (64bit) 61.0a1

It seems old version has no problem.
e.g.
Firefox Nightly (64bit) 57.0a1 (21Aug2017)
Same problem here. Tabs won't close with touchscreen input but will with mouse or keyboard

Lenovo Flex 5 Windows 10 Home x64
Firefox stable 59.0.2

Other applications work fine
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1446904
You need to log in before you can comment on or make changes to this bug.