Message list is not consistent with actual messages..

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
--
major
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Tilo Sloboda, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031103

I'm using IMAP for my mail - all folders are on the server. 

The list of all emails in my INBOX contains errors - e.g. 
an email is listed with a different Subject and Sender as it 
really has -- if i click on the message to display it, it 
appears to be a totally different one.. 

The message in question is a message I labeled "important" . 
It appears that Mozilla labeled the correct message - but the
display in the main window is wrong. 


Is there a way to make mozilla re-scan the contents of a folder? 

This might be somehow related to bug 131495. 



Reproducible: Didn't try

Comment 1

16 years ago
Please try a more current build.
QA Contact: olgam → huang
(Reporter)

Comment 2

16 years ago
it also happens with the 1.0rc1 build.

Comment 3

16 years ago
What IMAP server are you using? You can remove your INBOX.msf file from your
local imap server profile directory, which will delete the local cached headers.
However, this might lose all your labels, if your imap server is one that we
can't store labels on the server with.

you could generate a protocol log to see what's going on, though you'd need to
annotate it with which message you thought you were clicking on for it to be
helpful.

http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap
(Reporter)

Comment 4

16 years ago
not sure which IMAP server iPlanet is using - but i bet it is some 
flavour of Netscape's.. 

I tried to delete the INBOX.msf file - but it didn't change anything.. :(

Comment 5

16 years ago
sounds to me like your mailbox is corrupted on the server. If deleting the
INBOX.msf file doesn't help (assuming you deleted the right INBOX.msf, the one
for the imap account), then it's very likely a server problem. You could try
Netscape 4.7 and see if it has the same problem.
(Reporter)

Comment 6

16 years ago
Thx for the suggestion..

I used Netscape 4.x to crosscheck my IMAP inbox and everything appears 
to be correct there!

This is a bug in Mozilla.  

How shall we proceed?  Should I forward the offending message to some of you? 
Please advise.. 
reporter: does the problem still exist in a recent build as 1.1beta?
no answer
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.