Closed Bug 1430761 Opened 2 years ago Closed 2 years ago

Update to tzdata2018c

Categories

(Core :: JavaScript: Internationalization API, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla60
Tracking Status
firefox-esr52 --- fixed
firefox58 --- wontfix
firefox59 --- fixed
firefox60 --- fixed

People

(Reporter: anba, Assigned: anba)

Details

Attachments

(3 files, 1 obsolete file)

tzdata2018a will probably be released in the next few days (it's already tagged at https://github.com/eggert/tz, but not yet available at https://www.iana.org/time-zones and http://bugs.icu-project.org/trac/browser/data/trunk/tzdata/icunew). 

Updates:
>  São Tomé and Príncipe switched from +00 to +01.
>  Brazil's DST will now start on November's first Sunday.
>  Ireland's standard time is now in the summer, not the winter.

The Irland change [1] definitely needs to be tested, because I'm not sure every component works correctly with the notion of a negative DST in winter.

[1] https://github.com/eggert/tz/commit/b266263699ab1b02d7d4b7307e5303181bea00c1
Update title to refer to tzdata2018b (tzdata2018b == tzdata2018a + build fix for tzdata).
Summary: Update to tzdata2018a → Update to tzdata2018b
(In reply to André Bargull [:anba] from comment #0)
> The Irland change [1] definitely needs to be tested, because I'm not sure
> every component works correctly with the notion of a negative DST in winter.

-> https://mm.icann.org/pipermail/tz/2018-January/025820.html
The new release is tzdata2018c which no longer contains the problematic Ireland changes.
Summary: Update to tzdata2018b → Update to tzdata2018c
Attached patch bug1430761.patch (obsolete) — Splinter Review
Generated with:
  cd intl
  ./update-tzdata.sh -e $ICU60_BUILD_DIR/bin/icupkg 2018c
  cd ../js/src/builtin
  ./make_intl_data.py tzdata


I've verified the Africa/Sao_Tome and the Brazil changes are correctly applied:

Before:
js> new Intl.DateTimeFormat(undefined, {timeZone:"Africa/Sao_Tome", timeZoneName: "short"}).format()
"26.1.2018, GMT"
js> new Intl.DateTimeFormat(undefined, {timeZone:"America/Sao_Paulo", timeZoneName: "short"}).format(new Date(2018, 11-1, 1))
"1.11.2018, GMT-2"

After:
js> new Intl.DateTimeFormat(undefined, {timeZone:"Africa/Sao_Tome", timeZoneName: "short"}).format()
"26.1.2018, GMT+1"
s> new Intl.DateTimeFormat(undefined, {timeZone:"America/Sao_Paulo", timeZoneName: "short"}).format(new Date(2018, 11-1, 1))
"1.11.2018, GMT-3"
Assignee: nobody → andrebargull
Status: NEW → ASSIGNED
Attachment #8945752 - Flags: review?(jwalden+bmo)
Comment on attachment 8945752 [details] [diff] [review]
bug1430761.patch

Review of attachment 8945752 [details] [diff] [review]:
-----------------------------------------------------------------

Might need slight tweaking for the generated-file moves, maybe, fine otherwise.
Attachment #8945752 - Flags: review?(jwalden+bmo) → review+
Attached patch bug1430761.patchSplinter Review
Rebased to apply cleanly on current inbound. Carrying r+.
Attachment #8945752 - Attachment is obsolete: true
Attachment #8947434 - Flags: review+
Backport for ESR52.
Attachment #8947452 - Flags: review?(jwalden+bmo)
Backport for beta.
Attachment #8947453 - Flags: review?(jwalden+bmo)
Attachment #8947452 - Flags: review?(jwalden+bmo) → review+
Attachment #8947453 - Flags: review?(jwalden+bmo) → review+
Pushed by dluca@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/9fcc7a8c7da0
Update tzdata in ICU data files to 2018c. r=Waldo
Keywords: checkin-needed
Priority: -- → P1
Comment on attachment 8947453 [details] [diff] [review]
bug1430761-beta.patch

Approval Request Comment
[Feature/Bug causing the regression]: N/A

[User impact if declined]:
Wrong or inconsistent time zone data when calling methods from Intl.DateTimeFormat or methods internally using Intl.DateTimeFormat (that means Date.prototype.toLocale(Date|Time)String()). Inconsistencies are possible when the OS already uses the current tzdata release (tzdata 2018c), but our internal ICU version still uses tzdata 2017c. 
Based on the release notes for tzdata 2018c (https://mm.icann.org/pipermail/tz-announce/2018-January/000048.html), the update is of special interest for users in São Tomé and Príncipe (time zone switched from +00 to +01 on Jan 1 2018) and Brazil (starting this year, DST now begins on the first Sunday of November).

[Is this code covered by automated tests?]:
Yes.

[Has the fix been verified in Nightly?]:
Yes.

[Needs manual test from QE? If yes, steps to reproduce]: 
No.

[List of other uplifts needed for the feature/fix]:
None.

[Is the change risky?]:
No.

[Why is the change risky/not risky?]:
It only updates time zone data files.

[String changes made/needed]:
No.
Attachment #8947453 - Flags: approval-mozilla-beta?
Comment on attachment 8947452 [details] [diff] [review]
bug1430761-esr52.patch

[Approval Request Comment]

If this is not a sec:{high,crit} bug, please state case for ESR consideration:
User impact if declined: 
See comment #12.

Fix Landed on Version:
Firefox 60; Firefox 59 see comment #12.

Risk to taking this patch (and alternatives if risky): 
See comment #12.

String or UUID changes made by this patch: 
No.
Attachment #8947452 - Flags: approval-mozilla-esr52?
Comment on attachment 8947452 [details] [diff] [review]
bug1430761-esr52.patch

New updates for time zone changes for 2018. Let's get this into esr for 52.7.
Attachment #8947452 - Flags: approval-mozilla-esr52? → approval-mozilla-esr52+
Comment on attachment 8947453 [details] [diff] [review]
bug1430761-beta.patch

Time zone fixes should be in the next beta, 59.0b9.
Attachment #8947453 - Flags: superreview+
Attachment #8947453 - Flags: approval-mozilla-beta?
Attachment #8947453 - Flags: approval-mozilla-beta+
Why was this marked leave-open?
Flags: needinfo?(andrebargull)
I marked it as leave-open before I requested the Beta and ESR uplifts, so it doesn't get closed when the patch is merged into central. And I haven't yet removed the "leave-open" marker, because it seems like that the ESR patch still needs to land.
Flags: needinfo?(andrebargull)
SOP is to use bug resolution to track landing on m-c and status flags for branch uplifts :)
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Keywords: leave-open
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
You need to log in before you can comment on or make changes to this bug.