Closed Bug 1430788 Opened 2 years ago Closed 2 years ago

mach bootstrap broken on Gentoo

Categories

(Firefox Build System :: Android Studio and Gradle Integration, defect)

defect
Not set

Tracking

(firefox59 fixed)

RESOLVED FIXED
mozilla59
Tracking Status
firefox59 --- fixed

People

(Reporter: gsvelto, Assigned: gsvelto)

References

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1411654 +++

Bug 1411654 added nodejs to the packages installed during bootstrap but the package name used on Gentoo is not the correct one.
Indeed, the name should be "nodejs", not "node" (changing python/mozboot/mozboot/gentoo.py to use "nodejs" instead lets me get past this).
Duplicate of this bug: 1430791
Assignee: nobody → gsvelto
Status: NEW → ASSIGNED
(In reply to Gabriele Svelto [:gsvelto] from comment #0)
> +++ This bug was initially created as a clone of Bug #1411654 +++
> 
> Bug 1411654 added nodejs to the packages installed during bootstrap but the
> package name used on Gentoo is not the correct one.

This just isn't so -- https://searchfox.org/mozilla-central/rev/41925c0b6c6d58578690121de439d2a8d3d690f3/python/mozboot/mozboot/debian.py#38 shows that this was intentionally done by https://bugzilla.mozilla.org/show_bug.cgi?id=1424921.
Blocks: 1424921
No longer blocks: gradle-3.0
Comment on attachment 8942925 [details]
Bug 1430788 - Fix the 'nodejs' package name when bootstraping on Gentoo;

https://reviewboard.mozilla.org/r/213198/#review218882

If it works for you, it works for me.  Thanks!
Attachment #8942925 - Flags: review?(nalexander) → review+
(In reply to Nick Alexander :nalexander from comment #4)
> (In reply to Gabriele Svelto [:gsvelto] from comment #0)
> > +++ This bug was initially created as a clone of Bug #1411654 +++
> > 
> > Bug 1411654 added nodejs to the packages installed during bootstrap but the
> > package name used on Gentoo is not the correct one.
> 
> This just isn't so --
> https://searchfox.org/mozilla-central/rev/
> 41925c0b6c6d58578690121de439d2a8d3d690f3/python/mozboot/mozboot/debian.py#38
> shows that this was intentionally done by
> https://bugzilla.mozilla.org/show_bug.cgi?id=1424921.

You're right, I must have picked the wrong entry while looking at the commit log. Thanks for the review!
Pushed by gsvelto@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/74c55e7ec543
Fix the 'nodejs' package name when bootstraping on Gentoo; r=nalexander
https://hg.mozilla.org/mozilla-central/rev/74c55e7ec543
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
Product: Firefox for Android → Firefox Build System
Target Milestone: Firefox 59 → mozilla59
You need to log in before you can comment on or make changes to this bug.