Closed Bug 1430997 Opened 3 years ago Closed 3 years ago

Rename nsINode::IndexOf to nsINode::IndexOf_Slow

Categories

(Core :: DOM: Core & HTML, enhancement, P2)

58 Branch
enhancement

Tracking

()

RESOLVED FIXED
mozilla60
Tracking Status
firefox60 --- fixed

People

(Reporter: baku, Assigned: baku)

Details

Attachments

(1 file)

As part of bug 1425440 we must rename nsINode::IndexOf() and get rid of it as much as we can.
Attached patch indexOf.patchSplinter Review
Attachment #8943124 - Flags: review?(catalin.badea392)
Priority: -- → P2
Comment on attachment 8943124 [details] [diff] [review]
indexOf.patch

Review of attachment 8943124 [details] [diff] [review]:
-----------------------------------------------------------------

This is breaking the coding style and we're not deprecating this. IndexOfSlow or ComputeIndexOf? .. or ComputeIndexSlow?

r+ with a name that's camelCase.
Attachment #8943124 - Flags: review?(catalin.badea392) → review+
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/149124e4fde9
Rename nsINode::IndexOf to nsINode::ComputeIndexOf, r=catalinb
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/98c901dc8ae2
Rename nsINode::IndexOf to nsINode::ComputeIndexOf, r=me CLOSED TREE
https://hg.mozilla.org/mozilla-central/rev/149124e4fde9
https://hg.mozilla.org/mozilla-central/rev/98c901dc8ae2
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.