Closed Bug 1431 Opened 21 years ago Closed 21 years ago

This tables page leaks content

Categories

(Core :: Layout: Tables, defect, P2)

x86
Windows NT
defect

Tracking

()

VERIFIED DUPLICATE of bug 1240

People

(Reporter: angus, Assigned: karnaze)

References

()

Details

The column on the right with the heading "Market Watch" is leaking outside of
its parent (it actually displays OK when you initially load the page, then it
"pops out" during what looks like a reflow).

If you subsequently attempt to resize the window after loading this page, you'll
immediately bring NGLayout to it's knees; the only way to get out is
ctrl-alt-delete killing it.

I'm using 11/19/98 4pm Optimized bits.
Status: NEW → ASSIGNED
I'm going to ignore the "resizing freezes NGLayout" for now because
similar problems with the optimized bits are reported elsewhere.
The table layout bug is that we are not properly dividing a colspan'd cell's min
width to columns whose size comes from %.  The algorithm should be to divide the
colspan'd cell's min width first to %-width columns treating the
percentage as the column's desired width, then to coord-width columns, then to
proportionate-width columns, and finally to auto-width columns.
This change is too large to put in during a stability push, so I'm deferring
this bug until next week.
here is a much smaller test case:
<html><body background="http://graphics.boston.com/images/universal/tile.gif"
text=000000 link=31319c vlink=636363>
<table border=1 width=496 cellspacing=3 cellpadding=1>
<tr>
  <td width=67% valign=top>q  </td>
  <td valign=top bgcolor=#efefef border=0 cellpadding=0 cellspacing=0>
    <table border=0 cellpadding=2 cellspacing=0 bgcolor="#efefef">
    <tr>
      <td colspan=2 valign=top>
    		<img SRC="http://www.boston.com/images/banners/market.gif">
      </td>
    </tr>
    <tr bgcolor="efefef" valign=top>
      <td valign=top width=35%><font size=1
face="arial,helvetica">DOW</font></td>
      <td valign=top width=65% align=right><font size=1
face="arial,helvetica">9159.55 (+103.50)</font></td>
    </tr>
		<tr bgcolor="#efefef">
			<td valign=top colspan=2>
				<font color=maroon>
				<font size=2><b>Shaughnessy: Missed moments
making me a basket case</b></font>
				[ Column ]
				<br clear=all><p>
				<font size=-2>
				<hr size=1 noshade width=90%>
			</td>
		</tr>
		</table>
	</td>
</tr>
</table>

</body></html>
Assignee: buster → karnaze
Status: ASSIGNED → NEW
Status: NEW → ASSIGNED
Setting all current Open/Normal to M4.
per leger, assigning QA contacts to all open bugs without QA contacts according
to list at http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser
Whiteboard: (04/05) 3jrgm@qlink.queensu.ca - review partially complete
(per beppe) Looks like original bug was fixed. However, while test case OK,
the live site (same format/design) is not. Will look further tomorrow and
update with test case.
I'm not currently seeing this one on a Solaris 2.6 build from April 8, 1999, but
I do see the uninitialized memory reads that I reported as bug #4836, which
might be related.
I see that bug #4836 is now mark FIXED (Apr 10th). See also bug #1240, and bug
#1239 (both for boston.com). At this point, this bug is redundant (wrt #1240)
as the problem I noticed (above) is already convered by #1240.

 However, I did see a subtle problem on the Apr 9th content (using the Apr 9th
opt build win95). I have a good test case for it and could either file it here
or as a separate bug. It is more of 'layout flow' related than table related.
please file a separate bug with your test case.  Thanks!
Target Milestone: M4 → M6
I'm changing the summary from "This tables page leaks content, and resizing it
freezes NGLayout" to "This tables page leaks content", because I see on a WinNT
4/10 optimized build that the "Market Watch" column is too far to the right as
originally reported. The text field on the left side of the page may have
something to do with it, since it is bigger in Gecko than Nav4.5. Moving to M6.
Summary: This tables page leaks content, and resizing it freezes NGLayout → This tables page leaks content
Whiteboard: (04/05) 3jrgm@qlink.queensu.ca - review partially complete
Filed the test case for the other bug as bug #4956 (under Layout).

Also, I agree the text box widget on the left is the culprit (for this bug
#1431). In particular, the widget has an 'internal' left and right padding
that looks pretty much equal to the diff with 4.xP (on win). Just fill the
text box with text and you can see the 'dead space' on either side.
Moving to M8.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
This page currently demonstrates traces of bug 991, bug 5797, bug 8489, and
the CSS2 empty-inline-should-not-be-ignored issue. This bug is also a dup of
bug 1240, which covers these same issues. Marking a dup of bug 1240.


*** This bug has been marked as a duplicate of 1240 ***
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.