Closed Bug 1431201 Opened 2 years ago Closed 2 years ago

Crash in java.lang.NullPointerException: NativeException NullHandle() [T = nsWindow::GeckoViewSupport] at org.mozilla.gecko.mozglue.GeckoLoader.nativeRun(Native Method)

Categories

(GeckoView :: General, defect, critical)

58 Branch
All
Android
defect
Not set
critical

Tracking

(firefox58 wontfix, firefox59 fixed, firefox60 fixed)

RESOLVED FIXED
mozilla60
Tracking Status
firefox58 --- wontfix
firefox59 --- fixed
firefox60 --- fixed

People

(Reporter: jchen, Assigned: jchen)

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1427079 +++

This bug was filed from the Socorro interface and is
report bp-b960de08-e64c-495c-bada-7afaf0171226.
=============================================================

Top 10 frames of crashing thread:

0 libxul.so mozilla::jni::detail::ProxyNativeCall<nsWindow::GeckoViewSupport, mozilla::java::GeckoSession::Window, false, true, const mozilla::jni::Ref<mozilla::jni::Object, _jobject*>&, const mozilla::jni::Ref<mozilla::jni::Object, _jobject*>&>::Call<false, true, 0, 1> widget/android/jni/Natives.h:427
1 libxul.so mozilla::jni::detail::ProxyNativeCall<nsWindow::GeckoViewSupport, mozilla::java::GeckoSession::Window, false, true, const mozilla::jni::Ref<mozilla::jni::Object, _jobject*>&, const mozilla::jni::Ref<mozilla::jni::Object, _jobject*>&>::operator widget/android/jni/Natives.h:499
2 libxul.so nsWindow::WindowEvent<mozilla::jni::detail::ProxyNativeCall<nsWindow::GeckoViewSupport, mozilla::java::GeckoSession::Window, false, true, const mozilla::jni::Ref<mozilla::jni::Object, _jobject*>&, const mozilla::jni::Ref<mozilla::jni::Object, _jobject*>&>, false, const mozilla::jni::Ref<mozilla::java::GeckoSession::Window, _jobject*>&, nsWindow::GeckoViewSupport>::Run widget/android/nsWindow.cpp:161
3 libxul.so nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1039
4 libxul.so NS_ProcessNextEvent xpcom/threads/nsThreadUtils.cpp:510
5 libxul.so nsThreadManager::SpinEventLoopUntil xpcom/threads/nsThreadUtils.h:323
6 libxul.so NS_InvokeByIndex 
7 libxul.so XPCWrappedNative::CallMethod js/xpconnect/src/XPCWrappedNative.cpp:1948
8 libxul.so XPC_WN_CallMethod js/xpconnect/src/XPCWrappedNativeJSOps.cpp:929
9 libxul.so js::InternalCallOrConstruct js/src/jscntxtinlines.h:291

=============================================================

these crashes start to show up in fennec 58 with crash reason "MOZ_CRASH(JNI exception)" and the following java stack trace:

java.lang.NullPointerException: NativeException NullHandle() [T = nsWindow::GeckoViewSupport]
	at org.mozilla.gecko.mozglue.GeckoLoader.nativeRun(Native Method)
	at org.mozilla.gecko.GeckoThread.run(GeckoThread.java:407)
Assignee: nobody → nchen
Status: NEW → ASSIGNED
Comment on attachment 8945109 [details]
Bug 1431201 - Clear native queue when disposing window;

https://reviewboard.mozilla.org/r/215330/#review221332
Attachment #8945109 - Flags: review?(snorp) → review+
Pushed by nchen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f799207b5dd9
Clear native queue when disposing window; r=snorp
https://hg.mozilla.org/mozilla-central/rev/f799207b5dd9
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 60
Please request Beta approval on this when you get a chance. It grafts cleanly as-landed.
Flags: needinfo?(nchen)
Comment on attachment 8945109 [details]
Bug 1431201 - Clear native queue when disposing window;

Approval Request Comment
[Feature/Bug causing the regression]: N/A
[User impact if declined]: Possible crashes when backgrounding or quitting the app
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: Very small change and we're at the start of release cycle
[String changes made/needed]: None
Flags: needinfo?(nchen)
Attachment #8945109 - Flags: approval-mozilla-beta?
Comment on attachment 8945109 [details]
Bug 1431201 - Clear native queue when disposing window;

Looks like this fixed the crashes in Nightly. Let's uplift for 59 beta 6.
Attachment #8945109 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Product: Firefox for Android → GeckoView
Version: Firefox 58 → 58 Branch
Keywords: crash, regression
Target Milestone: Firefox 60 → mozilla60
You need to log in before you can comment on or make changes to this bug.