Shield about:preferences test fails "Clicking the view studies link opens about:studies"

RESOLVED FIXED in Firefox 59

Status

()

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: myk, Assigned: myk)

Tracking

Trunk
Firefox 59
Points:
---

Firefox Tracking Flags

(firefox59 fixed)

Details

Attachments

(1 attachment)

Running the tests in browser/extensions/shield-recipe-client/test/browser/browser_about_preferences.js fails "Clicking the view studies link opens about:studies" with "Got about:preferences#privacy, expected about:studies":

>TEST-UNEXPECTED-FAIL | browser/extensions/shield-recipe-client/test/browser/browser_about_preferences.js | Clicking the view studies link opens about:studies. - Got about:preferences#privacy, expected about:studies
>Stack trace:
>chrome://mochikit/content/browser-test.js:test_is:1269
>chrome://mochitests/content/browser/browser/extensions/shield-recipe-client/test/browser/browser_about_preferences.js:testViewStudiesLink:173

The test run also finds an unexpected tab at the end of the test run:

>TEST-UNEXPECTED-FAIL | browser/extensions/shield-recipe-client/test/browser/browser_about_preferences.js | Found an unexpected tab at the end of test run: about:studies - 

It looks like the test expects about:studies to open in the same tab, whereas it actually opens in a new tab.  Unlike bug 1430396, this is not a regression from bug 1379338, as it happens on a build from before that landed.

Assuming the current behavior is actually the expected behavior, here's a patch that updates the test to look for about:studies in the new tab (and closes that tab afterward).
Attachment #8943446 - Flags: review?(mcooper)
Comment on attachment 8943446 [details] [diff] [review]
expect about:studies to open in a new tab

Review of attachment 8943446 [details] [diff] [review]:
-----------------------------------------------------------------

I think the current behavior is expected, and updating the tests to match is a good idea. If nothing else, fixing the tests seems easier than changing the behavior.
Attachment #8943446 - Flags: review?(mcooper) → review+
Pushed by myk@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/4b7ad48ad5e5
expect about:studies to open in a new tab; r=mythmon
https://hg.mozilla.org/mozilla-central/rev/4b7ad48ad5e5
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
You need to log in before you can comment on or make changes to this bug.