Closed Bug 1431326 Opened 2 years ago Closed 2 years ago

regression: Tab loading indicator / throbber not showing on foreground tab while background tab is loading as well

Categories

(Core :: Graphics: WebRender, defect, P1)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1432541
Tracking Status
firefox-esr52 --- unaffected
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 --- disabled

People

(Reporter: alberts, Assigned: kats)

References

(Blocks 1 open bug)

Details

(Keywords: nightly-community, regression)

Attachments

(1 file)

In the latest Nightly 59.0a1 (2018-01-17) the tab loading indicator / throbber is not showing on the foreground tab until the background tab has finished loading.
See video loading-indicator-issue.ogv
This could be related to Webrender. I just set gfx.webrender.all to false and restarted. Though I thought I saw it on another machine as well this morning, which does not have Webrender enabled. Will assume WR for now and try remembering to test Nightly on the other machine again.
Maybe related to my profile. I have tested so far
- moz-regression: no issue
- save mode: no issue
- manually switching off all plugins: same issue
- setting webrender flag to 'false': same issue

What else could I test between manually switching off all plugins + the webrender flag and save mode?
I can reproduce this with mozregression 2018-01-20. I just set gfx.webrender.all to true then middle-click to open two tabs. Only one will get the loading indicator.
BTW I'm on Arch Linux.
Thanks for testing again lilydjwg :)
Component: Tabbed Browser → Graphics: WebRender
Product: Firefox → Core
Version: unspecified → Trunk
OS: Mac OS X → All
Hardware: x86 → All
Thank you!

Hold Ctrl down and make a doubleclick on "zeit", the first top sites item.
(Often I typed "retry" to verify my observation.)
mozregression --good 2017-12-01 --bad 2018-01-10 --pref layers.acceleration.force-enabled:true gfx.webrender.enabled:true gfx.webrender.blob-images:true image.mem.shared:true layout.display-list.retain:false startup.homepage_welcome_url:"about:newtab" browser.newtabpage.pinned:"[{\"url\":\"http://www.zeit.de/index\",\"label\":\"zeit\"}]"
> 12:55.32 INFO: Last good revision: 27841347525c5e83a67e086d6fd15758c625a9e3
> 12:55.32 INFO: First bad revision: 92ff8af42f6fd6db6e7255b287031d6ec298e031
> 12:55.32 INFO: Pushlog:
> https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=27841347525c5e83a67e086d6fd15758c625a9e3&tochange=92ff8af42f6fd6db6e7255b287031d6ec298e031

> 92ff8af42f6f	Kartikaya Gupta — Bug 1422057 - Remove now-unnecessary ::Equals checks. r=mstange
> b8931ab9dac9	Kartikaya Gupta — Bug 1422057 - Deduplicate DisplayItemClipChain instances on creation. r=mstange
> e448dd0f4aba	Kartikaya Gupta — Bug 1422057 - Add hash function and boilerplate for deduplicating DisplayItemClipChain via std::set. r=mstange
> b65a65089ffb	Kartikaya Gupta — Bug 1422057 - Extend the clipchain of a display item to the ancestor's clipchain if it is a strict superset. r=mstange
> 78ca58c296fa	Kartikaya Gupta — Bug 1422057 - Extract a local variable. r=mstange
> c12c951b5ecc	Kartikaya Gupta — Bug 1422057 - Avoid caching clips across stacking contexts with non-identity transforms. r=mstange
> 4dcb02cef0b7	Kartikaya Gupta — Bug 1422057 - Adjust some logging-related things to be more useful. r=mstange

Checked, whether non-WR Nightlies are affected:
mozregression --repo autoland --launch 92ff8af42f6fd6db6e7255b287031d6ec298e031 --pref layout.display-list.retain:false startup.homepage_welcome_url:"about:newtab" browser.newtabpage.pinned:"[{\"url\":\"http://www.zeit.de/index\",\"label\":\"zeit\"}]"
mozregression --repo autoland --launch 92ff8af42f6fd6db6e7255b287031d6ec298e031 --pref startup.homepage_welcome_url:"about:newtab" browser.newtabpage.pinned:"[{\"url\":\"http://www.zeit.de/index\",\"label\":\"zeit\"}]"
mozregression --launch 2018-01-21 --pref startup.homepage_welcome_url:"about:newtab" browser.newtabpage.pinned:"[{\"url\":\"http://www.zeit.de/index\",\"label\":\"zeit\"}]"

all 3 are good. non-WR Nightly is not affected
Blocks: 1422057
Has Regression Range: --- → yes
Has STR: --- → yes
Summary: Tab loading indicator / throbber not showing on foreground tab while background tab is loading as well → regression: Tab loading indicator / throbber not showing on foreground tab while background tab is loading as well
Picking this up since it's the regression window points to my patches. Might be the same root cause as bug 1430830, but this one seems easier to investigate.
Assignee: nobody → bugmail
This should be fixed in today's nightly. Please reopen if you still see it.
Status: NEW → RESOLVED
Closed: 2 years ago
No longer depends on: 1432541
Resolution: --- → DUPLICATE
Duplicate of bug: 1432541
You need to log in before you can comment on or make changes to this bug.