Partials generation broken with construct exception

RESOLVED FIXED

Status

defect
RESOLVED FIXED
Last year
Last year

People

(Reporter: sfraser, Assigned: sfraser)

Tracking

unspecified

Firefox Tracking Flags

(firefox58 fixed, firefox59 fixed)

Details

(Whiteboard: [stockwell infra])

Attachments

(1 attachment)

The latest rebuild of the funsize docker image broke it all:

https://tools.taskcluster.net/groups/bChKnxt1SHKQrO3XiAIf9g/tasks/HRtmTSsbQqeuBgsydu_zwg/runs/0/logs/public%2Flogs%2Flive.log


Traceback (most recent call last):
  File "/home/worker/bin/funsize.py", line 24, in <module>
    from mardor.reader import MarReader
  File "/usr/local/lib/python3.5/dist-packages/mardor/reader.py", line 14, in <module>
    from mardor.format import mar
  File "/usr/local/lib/python3.5/dist-packages/mardor/format.py", line 54, in <module>
    "id" / Const(Int32ub, 1),
  File "/usr/local/lib/python3.5/dist-packages/construct/core.py", line 1277, in __init__
    super(Const, self).__init__(subcon)
  File "/usr/local/lib/python3.5/dist-packages/construct/core.py", line 287, in __init__
    raise TypeError("subcon should be a Construct field")
TypeError: subcon should be a Construct field
Assignee: nobody → sfraser
The error is reproducible just doing `import mardor.format`.  mardor relies on the 'construct' module, which isn't pinned because it's brought in as a dependency.  They've just had an update, which seems broken.
Comment hidden (mozreview-request)
++ for pinning!

Comment 4

Last year
Pushed by aiakab@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/0a543687fd36
Pin all funsize dependency versions r=callek a=nightly-fix
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
This also broke 58.0rc build4... RyanVM is working on uplifting the pins and then we can do a build5
We tried a hacked-together graft of what hit m-c first, but that hit bustage. As a result, we ended up just pinning the version of construct and that appears to have worked.

https://hg.mozilla.org/releases/mozilla-release/rev/d304791fc530
https://hg.mozilla.org/releases/mozilla-release/rev/7f387e81a4a0

Comment 7

Last year
mozreview-review
Comment on attachment 8943582 [details]
Bug 1431381 Pin all funsize dependency versions

https://reviewboard.mozilla.org/r/213928/#review219870
Attachment #8943582 - Flags: review?(bugspam.Callek) → review+
Comment hidden (Intermittent Failures Robot)
We had to land a fix on m-r for the funsize balrog submitter too.

https://hg.mozilla.org/releases/mozilla-release/rev/40755aa80f41ee6df8995ae44044caf7a024b128
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Whiteboard: [stockwell disable-recommended] → [stockwell infra]
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.