[linux] Installer dies if no LANG environment variable

VERIFIED DUPLICATE of bug 143132

Status

--
critical
VERIFIED DUPLICATE of bug 143132
17 years ago
14 years ago

People

(Reporter: jrgmorrison, Assigned: dveditz)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I have a locally configured account on one of my test machines. That 
account was added, IIRC, just by adding the user to /etc/passwd and 
creating a home directory manually. 

At any rate, for that simple profile, there is no LANG environment 
variable when that user runs a shell.

With current builds, including the latest mozilla branch build 
2002-05-08-10-1.0.0 the installer dies at the point that it has 
downloaded all the xpi and is saying "Installing XPInstall Engine".
(Reporter)

Comment 1

17 years ago
Adding nsbeta1. We shouldn't depend on that var being set in order to install,
should we?

(I've been through these steps again in creating the account, but now I can't
seem to create an account that has no LANG var if I'm using the normal 'login'
shell. 
However, this machine has been configured to use 'autologin', which bypasses the
normal login and logs the user in without a password and starts X.).
Keywords: nsbeta1
(Reporter)

Updated

17 years ago
Summary: Installer dies if no LANG environment variable → [linux] Installer dies if no LANG environment variable
(Reporter)

Comment 2

17 years ago
er, to be clear, this is the Linux installer.
OS: Windows 2000 → Linux
(Reporter)

Comment 3

17 years ago
This appears to be bugscape http://bugscape.netscape.com/show_bug.cgi?id=15325
and my comment about autologin seems to not be the problem.

Comment 4

17 years ago
dup of bug 143132?

Updated

17 years ago
QA Contact: bugzilla → ktrina
(Reporter)

Comment 5

17 years ago
duping to bug 143132 on the presumption that this bug will be fixed by the 
checkin there. I guess I'll find out soon enough.

*** This bug has been marked as a duplicate of 143132 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

17 years ago
verified fixed/dup with 05/09 1.0.0 branch build on the linux box where I was 
crashing during install yesterday.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.