Closed Bug 1431778 Opened 2 years ago Closed Last year

CSS 3D panoramic cube has choppy images and crashes

Categories

(Core :: Graphics: Layers, defect, P3)

57 Branch
defect

Tracking

()

VERIFIED FIXED
mozilla61
Tracking Status
firefox-esr52 --- wontfix
firefox-esr60 --- wontfix
firefox57 --- wontfix
firefox58 --- wontfix
firefox59 --- wontfix
firefox60 --- wontfix
firefox61 --- verified

People

(Reporter: francois, Assigned: jnicol)

References

Details

(Keywords: regression, Whiteboard: [gfx-noted])

Attachments

(5 files)

Attached image Firefox_Problem3.jpeg
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.132 Safari/537.36

Steps to reproduce:

On Windows, Android Firefox 57.0.4,
1. open page: http://youriguide.com/sample-full
2. drag the panorama (left side of the screen) in any direction (horizontally, vertically, diagonally)



Actual results:

Attached is a screenshot of the cubic panorama viewer where 6 image tiles are placed on sides of a cube and 3D rotation is applied on mouse drag to rotate the cube. 3D transforms are implemented through CSS 3D styles.

While dragging mouse,
  - the panorama shows images chopped.
  - after a while Firefox crashes


Expected results:

The panorama should display a continuous and complete image that doesn't get chopped.
This bug is a pressing issue for us. We have gotten some complaints from customers because of this bug.
Attached image Firefox_Problem2.jpeg
Attached image Firefox_Problem.jpeg
Attached image Firefox_Problem4.jpeg
Francois: Can you please grab the crash report from about:crashes and paste it here? Thanks.
Flags: needinfo?(francois)
I can reproduce the graphics glitch on 52esr as well as nightly59.0a1 Windows10, but not on 45esr. So, I think this is a regression.
Keywords: regression
Product: Firefox → Core
Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=50792e13354b2407e37daa679c2cc8cccead1b4e&tochange=981ea1b8f2e741361eeaa2a42bf3c5fe607471e1

regressed by : Jamie Nicol — Bug 1274991 - Consider ancestor scale transforms when deciding whether to prerender transformed content. r=mstange
Blocks: 1274991
Status: UNCONFIRMED → NEW
Component: Untriaged → Graphics: Layers
Ever confirmed: true
(In reply to Alice0775 White from comment #7)
> Regression window:
> https://hg.mozilla.org/integration/mozilla-inbound/
> pushloghtml?fromchange=50792e13354b2407e37daa679c2cc8cccead1b4e&tochange=981e
> a1b8f2e741361eeaa2a42bf3c5fe607471e1
> 
> regressed by : Jamie Nicol — Bug 1274991 - Consider ancestor scale
> transforms when deciding whether to prerender transformed content. r=mstange

The range is for the graphics glitch. 
(I cannot reproduce the crash though)
Assignee: nobody → jnicol
Priority: -- → P3
Whiteboard: [gfx-noted]
I'll look in to this.

Hi Francois. Is this only with hardware acceleration disabled? (Like bug 1431745?) Do you have a link to any of the crash reports?
The panoramas being choppy while being rotated occurs both when hardware acceleration is enabled and disabled.
I wasn't able to reproduce the crash on our Windows computers, so I don't have a crash report.
However one of our users says it crashes.

This is what we got from them: 
"iGuide in Firefox is glitching. Images gets cut when moving in the tour and after couple of rotations the browser completely freeze and becomes unresponsive.
Its been awhile that this issue exist.

1. I'm using my custom built desktop, my Laptop which is (Dell XPS 15, 9650) and my Android phone (Sony XZ with Firefox mobile). They all have the same issue.

2. I'm using Windows 10 and Android 7.

3.My computers Firefox versions are 57.0.4 (64 bit). Chrome doesn't have any issue. its only Firefox.

I did disable the Hardware Acceleration which is by default on and it help to at least not freez the browser completely but still the tour is choppy and it froze for few seconds every time I rotate the 360 image."
Flags: needinfo?(francois)
Jamie, is that enough info to proceed?
Flags: needinfo?(jnicol)
Sorry this slipped off my radar. I couldn't reproduce the crashes but I do see the images disappearing. I will work on it now.
Flags: needinfo?(jnicol)
Comment on attachment 8967341 [details]
Bug 1431778 - Take 3D transforms in to account when deciding whether content is small enough to be prerendered.

https://reviewboard.mozilla.org/r/236038/#review242060
Attachment #8967341 - Flags: review?(matt.woodrow) → review+
Pushed by jnicol@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c3de9550cefb
Take 3D transforms in to account when deciding whether content is small enough to be prerendered. r=mattwoodrow
The above patch fixes part of the issue. It should be fine with acceleration enabled now. But there's an additional issue with acceleration disabled, so I'm leaving this bug open until it's fixed too.
Keywords: leave-open
Let's mark this as fixed actually, because bug 1431745 exists for the remaining problem on that page.
Status: NEW → RESOLVED
Closed: Last year
Keywords: leave-open
Resolution: --- → FIXED
Would it be possible to land an automated test for this?
Flags: needinfo?(jnicol)
Flags: in-testsuite?
Target Milestone: --- → mozilla61
Yes, I'll do that. Matt, is test_animation_performance_warning.html the best place for that?
Flags: needinfo?(matt.woodrow)
The website provided in description is not working and I could not reproduce this issue on Fx 57.0.4 using  other CSS 3D panoramic examples.
Could you provide another example? Thank you!
(In reply to Cristian Comorasu [:CristiComo] from comment #21)
> The website provided in description is not working and I could not reproduce
> this issue on Fx 57.0.4 using  other CSS 3D panoramic examples.
> Could you provide another example? Thank you!

I have just "unlocked" the web page. Please try loading it again.
Thank you, korya.github@gmail.com !

I reproduced the rendering issues using Fx 57.0.4, on Windows 10 x64.
I can confirm this issue is fixed, I verified using Fx 61.0b4, on Windows 10 x64, Ubuntu 14.04 LTS and mac OS 10.13.5.
Status: RESOLVED → VERIFIED
I just tried FirefoxDeveloperEdition 61.0b4 (64bit) on MacOS. The issue with choppy images is still there: https://youtu.be/sGXA4FgcNS4 .
(In reply to Jamie Nicol [:jnicol] from comment #20)
> Yes, I'll do that. Matt, is test_animation_performance_warning.html the best
> place for that?

Yes, I think so! Get Hiro to review any additions to it.
Flags: needinfo?(matt.woodrow)
Jamie, did we ever end up landing a test for this?
Flags: needinfo?(jnicol)
Flags: needinfo?(jnicol)
No I didn't. I forget the specifics but I couldn't get test_animation_performance_warning to work with scale animations, then it slipped down my todo list.
Flags: needinfo?(jnicol)
You need to log in before you can comment on or make changes to this bug.