Closed Bug 1431787 Opened 2 years ago Closed 2 years ago

WebRenderAPI.cpp build bustage on Beta

Categories

(Core :: Graphics: WebRender, defect, P1, blocker)

defect

Tracking

()

VERIFIED FIXED
mozilla59
Tracking Status
firefox-esr52 --- unaffected
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 + verified

People

(Reporter: RyanVM, Assigned: kats)

References

Details

(Keywords: regression)

Attachments

(2 files)

Looks like fallout from bug 1431211.

https://treeherder.mozilla.org/logviewer.html#?job_id=157442087&repo=mozilla-beta

gfx\webrender_bindings\webrenderapi.cpp(317) : warning C4722: 'mozilla::wr::WebRenderAPI::~WebRenderAPI': destructor never returns, potential memory leak
Flags: needinfo?(bugmail)
Attached patch PatchSplinter Review
Got r+ from lsalzman over IRC
Assignee: nobody → bugmail
Flags: needinfo?(bugmail)
Attachment #8944024 - Flags: review+
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/a1e2c443c259
Mark wr_dec_ref_arc safe to be called by the WebRenderAPI destructor when WR is not built. r=lsalzman a=RyanVM
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
This didn't do the job, because there's also a call to GetNamespace in the newly added code, which calls wr_api_get_namespace which is not marked destructor-safe. But we also can't mark it destructor-safe because the macro assumes a void return while this function does have a return value. So we need some special hackery.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Try push based on m-c tip: https://treeherder.mozilla.org/#/jobs?repo=try&revision=061b5650baf31fb8bc47c76b618b2437219b4f61
Try push based on beta tip: https://treeherder.mozilla.org/#/jobs?repo=try&revision=b94c3dfcf4e0929932b620bc9f366949d3c82430

(Given the extra hackery I had to add it's good to test that this builds on all platforms with and without webrender)
Try is green for linux/mac/android, and my local windows build seems to be good both with and without webrender. So this should be safe to land. Lee doesn't appear to be around at the moment so I'll land with r=me and leave the review flag up for post-review.
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/6bb6f3b25f9f
Followup to avoid the call to wr_api_get_namespace from the WebRenderAPI destructor. r=me a=RyanVM
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Target Milestone: --- → mozilla59
Attachment #8944058 - Flags: review?(lsalzman) → review+
Fixed in 59 already, but I'll track this anyway in case the status changes.
You need to log in before you can comment on or make changes to this bug.