Attaches text files as inline - bad behavior

VERIFIED DUPLICATE of bug 65794

Status

MailNews Core
Attachments
--
enhancement
VERIFIED DUPLICATE of bug 65794
16 years ago
9 years ago

People

(Reporter: Piotr Legiecki, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

When I attach text file mozilla makes it 'inline' type. It makes it sometimes
difficult to open/save such inline attachment. First of all www mail readers (as
IMP) treats such an email as one big mail and displays all email content in
browser window. Second, some companies requires to send them files as 'real'
file attachments not inline.

Reproducible: Always
Steps to Reproduce:
1. Compose new mail
2. Attach text file
3. Send it

Actual Results:  File is attached as inline

Expected Results:  I whish to attach it rather as regular binary files are
attached, or to have choice: inline or not.

Comment 1

16 years ago
Duplicate of bug 65794(Some attachments get Content-Disposition: inline
(incorrect))?

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 80632 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
This is not a DUP of bug #80632. It is not about _displaying_ inlines, but about
the way we attach text files, which always end up as inlines, although it is not
always desirable.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 65794 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
verifying dupe
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.