Closed Bug 1432140 Opened 3 years ago Closed 5 months ago

Links opened in Fennec from web apps/custom tabs don't go in the tab queue

Categories

(Firefox for Android Graveyard :: Web Apps (PWAs), defect)

ARM
Android
defect
Not set
normal

Tracking

(fennec?, firefox58 affected, firefox59 affected)

RESOLVED INCOMPLETE
Tracking Status
fennec ? ---
firefox58 --- affected
firefox59 --- affected

People

(Reporter: oana.horvath, Unassigned)

References

Details

Device: Sony Xperia Z5 Premium (Android 6.0.1)
Build: Nightly 59.0a1 (2018-01-22);

Steps to reproduce:
1. Open a progressive web app/ custom tab.
2. Long tap a link and tap "Open in Firefox".
3. Repeat 3 times to trigger the prompt for enabling tab queue. Enable tab queue.
4. Open a link again in firefox.

Expected result:
The links from the web app are added to the tab queue.

Actual result:
The prompt to enable tab queue prompt appears, but the links are still opening the browser, without being put in the queue.
We have completed our launch of our new Firefox on Android. The development of the new versions use GitHub for issue tracking. If the bug report still reproduces in a current version of [Firefox on Android nightly](https://play.google.com/store/apps/details?id=org.mozilla.fenix) an issue can be reported at the [Fenix GitHub project](https://github.com/mozilla-mobile/fenix/). If you want to discuss your report please use [Mozilla's chat](https://wiki.mozilla.org/Matrix#Connect_to_Matrix) server https://chat.mozilla.org and join the [#fenix](https://chat.mozilla.org/#/room/#fenix:mozilla.org) channel.
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → INCOMPLETE
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.