Yandex.Maps API doesn't work with tracking protection enabled

RESOLVED DUPLICATE of bug 1432650

Status

()

RESOLVED DUPLICATE of bug 1432650
10 months ago
10 months ago

People

(Reporter: arinasmart, Unassigned)

Tracking

(Blocks: 1 bug)

57 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 months ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20180103231032

Steps to reproduce:

API hosts are blocked in private mode or with tracking protection on for non-Yandex web-sites and as a result maps aren’t available for all our users in Firefox’s private mode.

Pages demonstrating the issue on 3d party web-sites:
https://www.domofond.ru/karta?SearchType=ForSale&AreaTypeDescription=r81&PropertyType=Apartment&Mapped=True 
http://narodmon.ru/ 

Yandex.Maps API is a JavaScript library to display interactive maps and use Yandex geo data on 3-d party services. During its work it could load some additional scripts and make other requests to our domains.
We’ve discussed the issue directly with disconnect team and they moved us to the content section but we still face the issue – API is loaded only on Yandex domains.

Updated

10 months ago
Blocks: 1101005
Component: Untriaged → Tracking Protection
OS: Unspecified → All
Hardware: Unspecified → All
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1432650
You need to log in before you can comment on or make changes to this bug.