nsHalfOpenSocket::SetFastOpenConnected MOZ_ASSERT((mFastOpenStatus... )) faiied

RESOLVED FIXED in Firefox 60

Status

()

defect
P1
normal
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: mayhemer, Assigned: mayhemer)

Tracking

Trunk
mozilla60
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox60 fixed)

Details

(Whiteboard: [necko-triaged])

Attachments

(2 attachments)

(Assignee)

Description

a year ago
Posted file mozilla-FX1.zip
clean today m-c debug

crashing h-o: 0x0000018ce4235c00

log attached, 100% repro for me.  this is very recent.


>	xul.dll!mozilla::net::nsHttpConnectionMgr::nsHalfOpenSocket::SetFastOpenConnected(NS_OK, false) Line 4596	C++	Symbols loaded.
 	xul.dll!mozilla::net::nsSocketTransport::OnSocketConnected() Line 1896	C++	Symbols loaded.
 	xul.dll!mozilla::net::nsSocketTransport::OnSocketReady(0x00000259b973a610, 0x0002) Line 2244	C++	Symbols loaded.
 	xul.dll!mozilla::net::nsSocketTransportService::DoPollIteration(0x0000007cb19fe8d0) Line 1152	C++	Symbols loaded.
 	xul.dll!mozilla::net::nsSocketTransportService::Run() Line 923	C++	Symbols loaded.
 	xul.dll!nsThread::ProcessNextEvent(false, 0x0000007cb19ff462) Line 1041	C++	Symbols loaded.
 	xul.dll!NS_ProcessNextEvent(0x00000259b0d806d0, false) Line 517	C++	Symbols loaded.
 	xul.dll!mozilla::ipc::MessagePumpForNonMainThreads::Run(0x00000259b0d74540) Line 334	C++	Symbols loaded.
(Assignee)

Updated

a year ago
Flags: needinfo?(dd.mozilla)
(Assignee)

Comment 1

a year ago
(note that my local inet conn is somewhat slow, maybe the reason I can so well repro)
Duplicate of this bug: 1432420
Assignee: nobody → dd.mozilla
Status: NEW → ASSIGNED
Flags: needinfo?(dd.mozilla)
I miss this state. It is set at:
https://dxr.mozilla.org/mozilla-central/source/netwerk/base/nsSocketTransport2.cpp#2223

and couple of lines after nsSocketTransport::OnSocketConnected is called which calls nsHttpConnectionMgr::nsHalfOpenSocket::SetFastOpenConnected.
Attachment #8944670 - Flags: review?(honzab.moz)
(Assignee)

Comment 4

a year ago
Comment on attachment 8944670 [details] [diff] [review]
bug_1432254.patch

Review of attachment 8944670 [details] [diff] [review]:
-----------------------------------------------------------------

thanks!

::: netwerk/protocol/http/nsHttpConnectionMgr.cpp
@@ +4590,5 @@
>      if (!mConnectionNegotiatingFastOpen) {
>          return;
>      }
>  
>      MOZ_ASSERT((mFastOpenStatus == TFO_NOT_TRIED) || 

maybe when you are here get rid of this trailing ws?
Attachment #8944670 - Flags: review?(honzab.moz) → review+
I'm sorry, I tried to apply the patch but I'm still hitting the assertion every time i ./mach run or I try to run a test. For me mFastOpenStatus == TFO_DISABLED
This did resolve the issue for me -- I guess there are two distinct underlying issues here.

Updated

a year ago
Priority: -- → P1
Whiteboard: [necko-triaged]
This also fixed the issue for me. Dragana, can we please land this soon?
Flags: needinfo?(dd.mozilla)
(Assignee)

Comment 8

a year ago
I'll take care of this bug.
Assignee: dd.mozilla → honzab.moz
Flags: needinfo?(dd.mozilla)
(Assignee)

Comment 9

a year ago
applies cleanly for me
Keywords: checkin-needed

Comment 10

a year ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/72d12033ae4d
In SetFastOpenConnected, mFastOpenStatus may be TFO_DATA_COOKIE_NOT_ACCEPTED as well. r=mayhemer
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/72d12033ae4d
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Hi Honza, I still hit the assertion on Win10. As in comment 5, I see mFastOpenStatus == TFO_DISABLED if I use ./mach run and try to access a remote page.
Ops, forgot the NI.
Flags: needinfo?(honzab.moz)
(Assignee)

Comment 14

a year ago
::mak, please open a new bug (don't want to reopen this one).  I will try to take a look if that is a bug or should just be listed in the assertion.

Please also provide output of 'netsh int tcp show global' in cmd (non-privileged is enough)
Flags: needinfo?(honzab.moz) → needinfo?(mak77)
Flags: needinfo?(mak77)
You need to log in before you can comment on or make changes to this bug.