Closed Bug 1432426 Opened 3 years ago Closed 3 years ago

Refactor tests using moveItem

Categories

(Toolkit :: Places, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
mozilla60
Tracking Status
firefox60 --- fixed

People

(Reporter: mak, Assigned: mak)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fxsearch])

Attachments

(1 file)

Some tests are using the moveItem API, we should refactor those
https://searchfox.org/mozilla-central/search?q=.moveItem(&path=
Whiteboard: [fx-search] → [fxsearch]
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Comment on attachment 8953756 [details]
Bug 1432426 - Remove synchronous Bookmarks::moveItem.

https://reviewboard.mozilla.org/r/222968/#review228954

::: services/sync/tests/unit/test_bookmark_tracker.js:1070
(Diff revision 1)
>      _("Clean up.");
>      await cleanup();
>    }
>  });
>  
>  add_task(async function test_onItemMoved() {

Isn't this test a near-duplicate of the test_async_onItemMoved_update below, and hence can just be removed?
Attachment #8953756 - Flags: review?(standard8) → review+
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/a33432da0fe9
Remove synchronous Bookmarks::moveItem. r=standard8
https://hg.mozilla.org/mozilla-central/rev/a33432da0fe9
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
You need to log in before you can comment on or make changes to this bug.