Closed Bug 1432645 Opened 3 years ago Closed 2 years ago

API to open URL bar results in new page

Categories

(WebExtensions :: General, enhancement, P2)

enhancement

Tracking

(firefox61 fixed)

RESOLVED FIXED
mozilla61
Tracking Status
firefox61 --- fixed

People

(Reporter: mconca, Assigned: mixedpuppy)

References

(Blocks 1 open bug)

Details

(Keywords: dev-doc-complete)

Attachments

(1 file)

Similar to bug 1420969, implement a browserSettings API that exposes the pref implemented in bug 1394304 to open URL bar (awesomebar) results in a new tab.
Severity: normal → enhancement
Component: Untriaged → WebExtensions: General
Priority: -- → P3
Product: Firefox → Toolkit
Bumping to P2. Would be nice if we can get it into the next release.
Priority: P3 → P2
Assignee: nobody → mixedpuppy
Keywords: dev-doc-needed
Comment on attachment 8969035 [details]
Bug 1432645 add browserSetting to flip urlbar.openintab,

https://reviewboard.mozilla.org/r/237718/#review243706
Attachment #8969035 - Flags: review?(lgreco) → review+
Pushed by mixedpuppy@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/154e987909aa
add browserSetting to flip urlbar.openintab, r=rpl
https://hg.mozilla.org/mozilla-central/rev/154e987909aa
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Is manual testing required on this bug? If Yes, please provide some STR and the proper webextension(if required), if No set the “qe-verify-“ flag.
Flags: needinfo?(mixedpuppy)
Flags: needinfo?(mixedpuppy) → qe-verify-
Duplicate of this bug: 1433657
Blocks: 1442843
I've added a page on this: https://developer.mozilla.org/en-US/Add-ons/WebExtensions/API/browserSettings/openUrlbarResultsInNewTabs

Let me know if we need anything else though.
Flags: needinfo?(mixedpuppy)
lgtm.  this doesn't do anything on android.
Flags: needinfo?(mixedpuppy)
> lgtm.  this doesn't do anything on android.

We should note this. Is that true only of this browser setting, or others? Sorry, I don't know a good way to find this out myself (don't have access to an Android device).
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.