Mail does not realize that there is an attachment on a incoming mail

VERIFIED WORKSFORME

Status

MailNews Core
Attachments
VERIFIED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Ben Spigel, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.9+) Gecko/20020328
BuildID:    2002032803

Just got an e-mail with an attached Zip file of about 300k, there was no option
to download it or save it. When I viewed the source of the messege, the
attachment showed as a long block of alpha-neumaric characters (think of a
very....very long PGP sig). 
It was a good Zip file because I was able to foward the messege to my self and
open it in Outlook Express. 
I closed mail several times, and restarted Mozilla several times with no effect.
To confirm it, I send several attached files using Outlook Express and Outlook
(the first one was sent via hotmail) with the same effect, no way to get the
attachment

Reproducible: Always
Steps to Reproduce:
1.Get e-mail messege with attachment
2 [details] [diff] [review].Try in vain to open it
3.cry

Sorry I can't give a more detained description, but thats all I did, well except
for the crying, it was more like sobbing

Actual Results:  Nothing, nothing at all

Expected Results:  I should have been presented with a way to get the attached file
Could you possibly save the source of that message to a text file and attach it
to this bug using
http://bugzilla.mozilla.org/attachment.cgi?bugid=143294&action=enter ?
(Reporter)

Comment 2

16 years ago
Created attachment 82935 [details]
source of the messege of the attachment which could not be opened

Sorry for not including it in the first place, didn't even think to. Hope you
solve this bug
I strongly suspect the problem is the missing end boundary after the second part....

Updated

16 years ago
QA Contact: trix → yulian
QA Contact: yulian → stephend

Comment 4

15 years ago
I can see the attachment just fine, but because of the missing boundery I cant
open the zip file after saving it, since it's corrupt.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Yes, verified.
Status: RESOLVED → VERIFIED
Summary: Mail does not relize that there is an attachement on a incoming mail → Mail does not realize that there is an attachment on a incoming mail
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.