When downloading news for offline reading articles are downloaded twice

VERIFIED DUPLICATE of bug 140555

Status

SeaMonkey
MailNews: Backend
VERIFIED DUPLICATE of bug 140555
16 years ago
14 years ago

People

(Reporter: Lorenzo Micheletto, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
When downloading newsgroup articles for every newsgroup selected
for download the statusbar first displays there are N headers
but the (when actually downloading articles) it shows
it is downloading 2*N articles.
The downloaded articles are actually N 
every article is downloaded twice.

My news server is powernews.libero.it
(the local newsserver for libero.it accounts).
Maybe it is really a bug or a problem with the powernews server.
David / Gary, isn't this a DUP of a bug that was recently fixed on the trunk?

Reporter, what build are you using? (Please always include this with your bugs).

Comment 2

16 years ago
There's this bug 140555.
Using offline option to download newsgroups results in 
the newsgroup store file (mozilla/profiles/username/foldername/News/
host-news/<newsgroup store file> having double headers.

I'm not sure if this what the reporter is talking about or not.
(Reporter)

Comment 3

16 years ago
It is not bug 140555, it is a different problem.

I'm not getting double headers, the articles' bodies looks
like they are downloaded twice.

In this moment i'm using build 2002050806 and i confirm the
bug 143298 is present.

Clicking on "About Mozilla" i get:
"Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0rc2) Gecko/20020508"

The OS is Win98SE.

Bug 143298 happens while downloading article bodies (*not* headers)
for offline reading.
The *total* article count showed when dowloading articles is *twice*
the *total* header  count showed when downloading articles' headers
and articles' bodies are downloaded twice (or at least is what
it looks likely to me).

The first time i noticed the thing (weeks ago), i guessed
what was displayed on the status bar when downloading articles
was the total header+body count, but some days ago, while downloading
a newsgroup where a flamewar was in progress (with huge replies)
i noticed that what i supposed it was header and body downloaded in sequence
it was actually a full article downloaded *twice*
(or at least it was the body downloaded twice)
because i noticed the time needed to download an article
was the same for every couple of consecutive articles.

My home is in a suburban/rural area and i have a slow
modem connection, so while downloading i could see
the difference between short and very long articles.

As i said in the initial bug report, my provider
is libero.it and the newsserver is "local" (not accessible
outside the provider's network) and maybe it is a problem
between Mozilla and the newsserver.


At work i have an high speed DSL connection, so if you want
i can download any tool or Mozilla build you will tell me to use
to identify what's going on between Mozilla and the newsserver.

L. Micheletto 

Comment 4

16 years ago
Reporter,
can you tell us exact/detailed steps you do to reproduce please?

When you mean download: do you mean you click on the newsgroup
and you get prompted to download like 500 new mesgs? Or
are you talking about clicking offline icon/Doing a Download/Sync
now and downloading your news mesgs that way?

You might want to attach a news protocol log:
http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#nntp

(Reporter)

Comment 5

16 years ago
Created attachment 83213 [details]
NNTP log for bug 143298

The bug happens when doing a "Download/Sync now".
I did a protocol log and looks like
that if there are N articles the log shows 2*(N-1) articles downloaded.
For every newsgroup to download, while performing the download/sync
first it shows on the statusbar:
   "Downloading <article number> of <N> headers"
and then (when dowloading articles):
   "Downloading articles <article number>-<2*N> in <newsgroup>"

The compressed log is included as attachment.

L. Micheletto
(Reporter)

Comment 6

16 years ago
Created attachment 83214 [details]
NNTP log in zip format for bug 143298

Sorry, i supposed binary format was correct for zip files.
Here is the .zip fiel in the correct format.

Comment 7

16 years ago
the fix for bug 140555 is only in the trunk mozilla builds, not in rc2 (or rc1)
and bug 140555 is the same, and IS about downloading message bodies, not message
headers, twice.

*** This bug has been marked as a duplicate of 140555 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED
Component: Networking: News → Offline
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.