Sync telemetry should report more detail about http errors

RESOLVED FIXED in Firefox 60

Status

()

enhancement
P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: markh, Assigned: tcsc)

Tracking

Trunk
Firefox 60
Points:
---

Firefox Tracking Flags

(firefox60 fixed)

Details

Attachments

(1 attachment)

Looking at sync telemetry, we see a large number of errors reported as ("othererror", "error.engine.reason.something"). In almost all cases, this tends to mean an unexpected http status code (other than 5xx errors which are reported). This makes it difficult to determine what might be going wrong.

For example, on some days, over 5000 unique devices see "record_upload_fail" doing the history engine, and this doesn't seem to correlate with stats from the server  - having the status code is likely to give us more insights into what the problem actually is. These errors seems transient, but still aren't ideal.

We should even do this for "error.engine.reason.batch_interrupted" - having this reported as ("httperror", 412) gives us the same information.

Note that doing this would mean we lose information about whether the problem was during upload or download. That seems a reasonable tradeoff for a first cut - we could consider adding the http method used in another bug if we found it would be useful.
Duplicate of this bug: 1433004
Priority: -- → P1
Assignee: nobody → tchiovoloni
Comment on attachment 8946381 [details]
Bug 1432995 - Check for HTTP error codes before error strings in the sync ping.

https://reviewboard.mozilla.org/r/216326/#review222270

Awesome, thanks!
Attachment #8946381 - Flags: review?(markh) → review+
Pushed by tchiovoloni@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7bc2c9f1383e
Check for HTTP error codes before error strings in the sync ping. r=markh
https://hg.mozilla.org/mozilla-central/rev/7bc2c9f1383e
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 60
You need to log in before you can comment on or make changes to this bug.