"Web search for" context menu option isn't working with non-English chars

RESOLVED DUPLICATE of bug 145375

Status

SeaMonkey
Search
RESOLVED DUPLICATE of bug 145375
16 years ago
10 years ago

People

(Reporter: Marek Wawoczny, Assigned: Samir Gehani)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
"Web search for" context menu option isn't working with non-English chars - non-English chars are changed to "?".

See attached screenshot, after searching for "odnale¼æ" non-English chars are encoded to %3F%3F (decoded "??") instead of %BC%E6 (decoded "¼æ").

Mozilla/5.0 (Windows; U; Windows NT 5.0; pl-PL; rv:1.0.0+) Gecko/20020509
(Reporter)

Comment 1

16 years ago
Created attachment 82950 [details]
Screenshoot of Google search

Comment 2

16 years ago
could this be related to Bug 102984?  Because I think using the context menu
item for "Web search for" does the same thing as typing a string into the URL
bar and choosing "search for" in the pull down menu right below the bar, no?

Comment 3

16 years ago
sorry for the spam.  also see Bug 119825, maybe ask if your issue here belongs
there.  i can't tell for sure.

Comment 4

16 years ago
This is definitely a sherlock plugin issue. The plugin has to have the enctype
and similar attributes set correctly. Dupe of bug 145375 as far as google is
concerned. If you see the same thing on other search engines, bug the mycroft
project instead http://mycroft.mozdev.org/

*** This bug has been marked as a duplicate of 145375 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.