Closed Bug 1433172 Opened 2 years ago Closed 2 years ago

Drop the pref that controls the policy engine

Categories

(Firefox :: Enterprise Policies, enhancement)

60 Branch
enhancement
Not set

Tracking

()

RESOLVED FIXED
Firefox 61
Tracking Status
firefox60 --- fixed
firefox61 --- fixed

People

(Reporter: Felipe, Assigned: Felipe)

References

Details

(Keywords: dev-doc-needed)

Attachments

(1 file)

Currently, the policy engine is turned off behind a pref: browser.policies.enabled

To release the engine we should remove this pref and make it unconditionally enabled, because a user shouldn't be able to disable it.
Blocks: 1433173
Assignee: nobody → felipc
Status: NEW → ASSIGNED
Note: we decided to wait a little bit before dropping this pref. For now, we'll toggle it to true to allow early testing on Nightly and Beta, through bug 1442759
See Also: → 1442759
Comment on attachment 8954857 [details]
Bug 1433172 - Drop the pref that controls the policy engine.

Dropping request for now
Attachment #8954857 - Flags: review?(dtownsend)
The timeline for the #define EARLY_BETA_OR_EARLIER is ending soon on this cycle, so it's time to fully drop the pref now. The policy engine has been enabled by default on Nightly for about 3 weeks, and on beta 60 since the beginning of the beta cycle.
Comment on attachment 8954857 [details]
Bug 1433172 - Drop the pref that controls the policy engine.

https://reviewboard.mozilla.org/r/224010/#review236716
Attachment #8954857 - Flags: review?(dtownsend) → review+
Pushed by felipc@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/d13aee6372bf
Drop the pref that controls the policy engine. r=mossop
https://hg.mozilla.org/mozilla-central/rev/d13aee6372bf
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
Comment on attachment 8954857 [details]
Bug 1433172 - Drop the pref that controls the policy engine.

Approval Request Comment
[Feature/Bug causing the regression]: Enterprise policies
[User impact if declined]: This is needed to release enterprise policies and to keep them active on beta. Right now they are conditioned to EARLY_BETA_OR_EARLIER, which this patch removes
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: It will just keep the enterprise policies active
[String changes made/needed]: none
Attachment #8954857 - Flags: approval-mozilla-beta?
Comment on attachment 8954857 [details]
Bug 1433172 - Drop the pref that controls the policy engine.

I'm about to flip the early beta flag, so that's timely.  beta60+, should be in 60.0b8.
Attachment #8954857 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.