Allow moving WebExtension icon in address bar into or out of page action menu

RESOLVED DUPLICATE of bug 1395387

Status

()

enhancement
RESOLVED DUPLICATE of bug 1395387
Last year
Last year

People

(Reporter: c4609174, Unassigned)

Tracking

57 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

Last year
Allow the user to move the icon into and out of the "…" (overflow) menu in the address bar. Currently, this is only possible for the built-in icons, but not for WebExtensions.
Reporter

Comment 1

Last year
This is e.g. useful for https://github.com/kkapsner/CanvasBlocker/issues/177
Component: Address Bar → Toolbars and Customization

Comment 2

Last year
I don't really understand. The context menu entries on the page action items should let you add/remove the item from the location bar. This was fixed in bug 1395387 and follow-ups, and should be fixed in 58 and later (released earlier this week).

Can you elaborate on what version of Firefox you're testing with, what add-on, and what you are/aren't seeing happen when trying to use these context menus, and how that does/doesn't match your expectations?
Flags: needinfo?(c4609174)
Summary: Allow moving WebExtension icon in address bar into or out of overflow menu → Allow moving WebExtension icon in address bar into or out of page action menu

Updated

Last year
Blocks: 1395387
Reporter

Comment 3

Last year
Ah okay, did not saw that. It's indeed what I want and I can confirm that it is fixed. Thanks.
Flags: needinfo?(c4609174)
Reporter

Updated

Last year
Status: UNCONFIRMED → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1395387
You need to log in before you can comment on or make changes to this bug.