Closed Bug 1433299 Opened 3 years ago Closed 3 years ago

Link in summary is broken

Categories

(bugzilla.mozilla.org :: User Interface, defect)

Production
defect
Not set
normal

Tracking

()

VERIFIED FIXED

People

(Reporter: arai, Assigned: kohei.yoshino)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

45 bytes, text/x-github-pull-request
Details | Review
haha, woops!
Holy s**t.
Duplicate of this bug: 1434533
Why don't you use `overflow-wrap: break-word` instead of inserting <wbr> everywhere?
Just noticed this and was about to file a bug - Kohei, can you take this on?
Yes this is my regression... will fix it.
Assignee: nobody → kohei.yoshino
Status: NEW → ASSIGNED
Keywords: regression
Assignee: kohei.yoshino → dylan
Duplicate of this bug: 1438166
Duplicate of this bug: 1439132
Duplicate of this bug: 1441355
Attached patch bug-1433299.patch (obsolete) β€” β€” Splinter Review
remove the wbr FILTER to restore link functionality to the summary fields.
Assignee: dylan → glob
Attachment #8954267 - Flags: review?(dylan)
i agree with :emk that using `overflow-wrap: word-break` is the better solution; however, i keep on getting bit by this and removing the injection of <wbr> elements is a trivial change.
Duplicate of this bug: 1441739
Using `overflow-wrap` is an easy solution, not a better solution. That's why MDN and my FxSiteCompat.com have opted for `<wbr>`. This issue can be solved by modifying the regular expression.
Attached file pull request β€”
(In reply to Kohei Yoshino [:kohei] from comment #13)
> Using `overflow-wrap` is an easy solution, not a better solution.

Why?
Already explained in Bug 1428270.
Er, if I could explain a bit more, `overflow-wrap: word-break` doesn't always work well, e.g. Bug 1392433 that led to the original Bug 1428270. `<wbr>` meanwhile has been proved by other sites to work better especially with camel cases that can often been seen on BMO.

Basically the `overflow-wrap` property needs a new value handling such cases properly, but I don't think it will happen soonish :S (Well, it took 2 _decades_ for CSS editors to add the `calc()` function)
Assignee: glob → kohei.yoshino
Attachment #8954267 - Attachment is obsolete: true
Attachment #8954267 - Flags: review?(dylan)
so the wbr filter just has to be smarter.
Duplicate of this bug: 1442853
Duplicate of this bug: 1443441
The fix is coming today.
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.