Bad display of <select> dropdown across frame border when frameset inside iframe

RESOLVED DUPLICATE of bug 136441

Status

()

P3
normal
RESOLVED DUPLICATE of bug 136441
17 years ago
3 months ago

People

(Reporter: crsng1, Assigned: john)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc1)
Gecko/20020417
BuildID:    2002041711

The dropdown display of a <select> tag doesn't get painted correctly in the part
that crosses the frame boundary. I have noticed this behaviour in one particular
condition when using a nested <frameset> loaded in an <iframe>. Note that the
<select> dropdown crosses a frame boundary part of the <frameset> and not the
<iframe> boundary.

Problem appeared in 10RC1.

Reproducible: Always
Steps to Reproduce:
See the attached problem example ZIP file. Just load the file level1.htm and
click on the select box. If you load directly file level2.htm so that the
<frameset> doesn't get loaded in the <iframe> it is ok. Another way to get rid
of the problem is to flatten the nested <frameset> in file leve2.htm as
described in comments.
(Reporter)

Comment 1

17 years ago
Created attachment 82976 [details]
ZIP file that contains HTML files to load a nested frameset into an iframe

level1.htm -> the iframe definition that loads file level2.htm
livel2.htm -> the nested frameset definition that loads level3-[1..3].htm files
(Assignee)

Updated

17 years ago
Attachment #82976 - Attachment mime type: application/octet-stream → text/html
(Assignee)

Comment 2

17 years ago
Comment on attachment 82976 [details]
ZIP file that contains HTML files to load a nested frameset into an iframe

oops, my booboo
Attachment #82976 - Attachment mime type: text/html → application/octet-stream
(Assignee)

Comment 3

17 years ago
What does it do?  Show gray when it reaches past the boundary?
(Reporter)

Comment 4

17 years ago
When you load level1.htm, the <select> dropdown is not painted correctly past
the frame boundary. The rectangle has the right size AND the options can be
selected by using the arrows even past the frame boundary. The dropdown is
painted in gray and black past the frame boundary.

Just found bug #136441 that look similar: same select painting problem but
across an iframe boundary.
(Reporter)

Comment 5

17 years ago
Problem still present in 10RC2 {Build ID: 2002051006}.
I did not explicitly mention in my previous comments that the problem first
appeared in 10RC1 and was not present in 099.
(Assignee)

Updated

17 years ago
Depends on: 136441

Updated

17 years ago
Priority: -- → P3
(Reporter)

Comment 6

17 years ago
Problem fixed in Mozilla 1.1b and depended on bug 136441 which is resolved. 

Comment 7

16 years ago
if it was fixed by that, then safe to resolve this as a duplicate of that bug.

*** This bug has been marked as a duplicate of 136441 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
No longer depends on: 136441
Resolution: --- → DUPLICATE

Updated

3 months ago
Product: Core → Core Graveyard
Component: Layout: HTML Frames → Layout: Images
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.