If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Dragging an image to the desktop or other app results in the URL rather than the image being dropped

VERIFIED DUPLICATE of bug 97413

Status

SeaMonkey
UI Design
--
minor
VERIFIED DUPLICATE of bug 97413
16 years ago
13 years ago

People

(Reporter: Michael P. McHugh, Assigned: Samir Gehani)

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

Dragging an image to the desktop or other app results in the URL rather than the
image being dropped. This is inconsistent with Netscape, IE and every other
browser I've used. The only way to save an image is the right-click Save as menu...

At the very least, there should be a preference on Mac OS 9 and X to use a drag
and drop image behaviour instead.

Reproducible: Always
Steps to Reproduce:
1. Drag an image from a browser window to desktop or other app
2. See URL or Internet Location Document be dropped instead of image.
3.

Expected Results:  I expect the image itself to be dropped to where I drag it,
not the URL to it.

Comment 1

16 years ago
This bothers me as well.  I agree that it's contrary to expected browser
behaviour, as illustrated in iCab, IE, Netscape 4, etc.  I tried holding various
modifier keys during the drag & drop sequence (such as option, which gives me a
nice "+" sign), to no avail...

Personally, I like & recommend iCab's behaviour:
Dragging an image saves the image.
Dragging an image with the command key down saves the destination URL (if
there's a link).
Dragging an image with with the option key down saves the contents of the
destination URL (if there's a link).

Those rules work interchangeably with text elements. Other browsers may use them
as well. 

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 97413 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
v
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.