Closed Bug 1433512 Opened 2 years ago Closed 11 months ago

Consider fixing server bookmark inconsistencies at merge time, or rejecting invalid trees

Categories

(Firefox :: Sync, enhancement, P3)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1515784

People

(Reporter: Lina, Unassigned)

Details

During merging, we won't intentionally try to fix inconsistencies on the server, because we might clobber a client that was interrupted uploading its records. We also want to avoid infinite sync loops, where two clients never converge, and each tries to make the other consistent by reuploading the same records.

However, because we opt to continue syncing even if the remote tree is incomplete, we can still clobber partial uploaders if an inconsistent remote item was also changed locally.

Atomic uploads make this less likely, but won't fix corruption that's already there for existing users. Today, Android tries to fix the server to match its view of the world, while iOS rejects invalid trees and halts syncing entirely.

Historically, we've erred on the side of eventual consistency, and wanting to keep the user syncing, so this will likely be a WONTFIX. But I wanted to capture the discussion in a bug for posterity.
Priority: -- → P3
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1515784
You need to log in before you can comment on or make changes to this bug.