Closed Bug 1433681 Opened 7 years ago Closed 7 years ago

"Pause on exceptions" button disappeared in Dev Edition debugger

Categories

(DevTools :: Debugger, defect)

59 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: impinball, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20180122192913

Steps to reproduce:

Updated from FF 58 to FF 59 (Dev edition on both), via a custom profile, and reloaded the debugger.


Actual results:

The "pause on exceptions" button disappeared.


Expected results:

The "pause on exceptions" button to remain there.
Edit: the first known bad version for me was FF Dev Edition 59b2 and the last known good one was the last 58 release. That should help narrow down the bisect a little bit.
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
20180127220259

https://hg.mozilla.org/integration/mozilla-inbound/json-pushes?changeset=4bcb9a936d3394b2ed3206fa8ca8bd247acd69a5&full=1
Blocks: 1429238
Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
Component: Untriaged → Developer Tools: Debugger
Ever confirmed: true
Keywords: regression
OS: Mac OS X → All
Hardware: x86 → All
Thanks for filing, we tried moving the "pause on exceptions" to a + button in the breakpoints pane. This will be reverted soon though as the UX work is not done.
Okay. I found it there. It isn't where I would normally expect it to be, though (who would think to look at the breakpoint pane for "pause on exceptions" when "pause on next statement" is available in a much more visible location).

If this constitutes it as "not a bug" (i.e. a design issue, not a functional issue), feel free to close this.
I'll close this as "FIXED" given comment 3 and comment 4 but feel free to re-open.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Calling this invalid since it's operating by design if I understand correctly. This is mostly just a bookkeeping move, don't read anything into it beyond that. Thanks for filing the report, Isiah!
Resolution: FIXED → INVALID
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: