incorrect installer target location for windows, gets virtualized even though x64

RESOLVED INVALID

Status

()

Firefox
Installer
RESOLVED INVALID
27 days ago
25 days ago

People

(Reporter: Jim Michaels, Unassigned)

Tracking

58 Branch
x86_64
Windows
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

27 days ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20180118215408

Steps to reproduce:

for x64, the installer for ff installs and upgrades to C:\Program files (x86)\ instead of to the proper location for x64, C:\Program Files\
in windows vista and above.


Actual results:

- application gets virtualized by windows
- because of location it gets installed to, it executes as a 32-bit application in the virtual store (storage, not app store) and is thus limited to 4GB-videoRAM-OSOverhead -applicationsRAMUsage which information you can pay for later if you need it just email me in 2027 about it.



Expected results:

should install to C:\Program Files\ in windows x64 and also in any case for windows 9x/me/nt/xp/2000 except for xp64.

Updated

26 days ago
Component: Untriaged → Installer
OS: Unspecified → Windows
Hardware: Unspecified → x86_64
When we update 32-bit installations to migrate them to 64-bit, we intentionally do not change the install path, to avoid various complications that might come out of that. Also, our installer will sometimes intentionally install a 32-bit build on a 64-bit system, if the system has 2GB of RAM or less installed or if it is a Lenovo system running some of their bundled software that is known to conflict with our 64-bit builds. You can also run the 32-bit full installer to always get a 32-bit installation.

Which Program Files directory a process runs out of does not affect its virtualization status or address space size/layout; it is not possible for Windows to take a 64-bit binary and execute it in the address space that it would give to a virtualized 32-bit process. If you are seeing processes limited to a 4GB user address space, it is because you are running a 32-bit build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 25 days ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.