Closed Bug 1433755 Opened 3 years ago Closed 3 years ago

Thumb dragging in the popup(alert) dialog scrolls parent window instead of the popup dialog

Categories

(Core :: Graphics: WebRender, defect, P1)

x86_64
All
defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox-esr52 --- unaffected
firefox58 --- unaffected
firefox59 --- unaffected
firefox60 --- disabled

People

(Reporter: alice0775, Assigned: kats)

References

Details

Attachments

(1 file)

Attached file testcase
Reproducible : always if WebRender is enabled

Steps to reproduce:
1. Enable WebRender
    user_pref("gfx.webrender.all", true);
2. Open attached testcase. And click on a link "click" so that a dialog box will pop up
3. Try to scroll the dialog with scroll thumb in the dialog

Actual results:
Scroll parent window

Expected results:
Scroll the dialog
I'm not able to reproduce on OS X. With both gfx.webrender.hit-test enabled and disabled it works as expected.
Ah, I can reproduce on windows. But turning on gfx.webrender.hit-test seems to fix it.
Depends on: 1421380
Nightly 60 x64 20180128100650 de_DE @ Debian Testing (KDE, Radeon RX480)
fresh profile: gfx.webrender.all

I can reproduce. Fixed by gfx.webrender.hit-test;true.
Once hit-test is the default, we can close this.
Assignee: nobody → bugmail
Depends on: stage-wr-nightly
Priority: -- → P1
Fixed by bug 1421380.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.