Crash in libGLESv2_adreno.so@0x309c2a

NEW
Unassigned

Status

()

Firefox for Android
General
P3
critical
26 days ago
15 hours ago

People

(Reporter: landon, Unassigned)

Tracking

Firefox 58
Unspecified
Android
Points:
---

Firefox Tracking Flags

(fennec+, firefox58 affected, firefox59 unaffected, firefox60 unaffected)

Details

(crash signature)

(Reporter)

Description

26 days ago
This bug was filed from the Socorro interface and is
report bp-92e99989-f572-4589-a1bb-c7afb0180120.
=============================================================

Top 10 frames of crashing thread:

0 libGLESv2_adreno.so libGLESv2_adreno.so@0x309c2a 
1 libGLESv2_adreno.so libGLESv2_adreno.so@0x1a1497 
2 dalvik-main space (region space) (deleted) dalvik-main space @0x2d400083 
3 dalvik-main space (region space) (deleted) dalvik-main space @0x2d400083 
4 dalvik-main space (region space) (deleted) dalvik-main space @0x2d400083 
5 dalvik-main space (region space) (deleted) dalvik-main space @0x2d400083 
6 libGLESv2_adreno.so libGLESv2_adreno.so@0x1a825d 
7 libGLESv2_adreno.so libGLESv2_adreno.so@0x18828f 
8 dalvik-main space (region space) (deleted) dalvik-main space @0x321bbffe 
9 dalvik-main space (region space) (deleted) dalvik-main space @0x31c6fffe 

=============================================================
(Reporter)

Comment 1

26 days ago
This happens on a regular basis for me. Once or twice an hour. I think it's happened for several versions. My first memory of the crash was a year or so ago, I think. I just chalked it up to an unstable custom ROM. This was captured on my stock Pixel 2 with the latest updates.
Confirming since I see crashes on both new pixel devices (Pixel 2 and Pixel XL) on 57 as well as 58. ni on Ioana to see if they have one of those devices to test.

Some comments:

*randomly scrolling on page when it went blank and then the crash happened 
*crashed when returning to the home page 
*I was reading something page by page when it froze.
Status: UNCONFIRMED → NEW
status-firefox58: --- → affected
status-firefox59: --- → unaffected
status-firefox60: --- → unaffected
Ever confirmed: true
Flags: needinfo?(ioana.bugs)
Does it happen without uBlock installed?
Flags: needinfo?(landon)
Tried reproducing this using a Pixel (Android 8.1.0) with and without uBlock installed, but everything worked fine on the device. We do not have a Pixel 2 or Pixel XL here on hand to verify on any of those devices, will wait to see if Ioana can reproduce.
(Reporter)

Comment 5

24 days ago
I've uninstalled uBlock. I will let you know what happens.
Flags: needinfo?(landon)
(Reporter)

Comment 6

19 days ago
I'm convinced it's uBlock now.
So based on Comment 6, you didn't have any more crashes after uninstalling uBlock?
Flags: needinfo?(landon)
Although I cannot seem to get overall correlations, some of the individual reports I clicked on for 58 had no extensions installed.
(Reporter)

Comment 9

15 days ago
I personally have not had crashes after uninstalling the plug-in. Should I report on the plug-in?
Flags: needinfo?(landon)
(Reporter)

Updated

15 days ago
Duplicate of this bug: 1436667
(In reply to landon from comment #9)
> I personally have not had crashes after uninstalling the plug-in. Should I
> report on the plug-in?

We can reach out to the addon author, but as I noted both signatures have users crashing without any extensions. 

The lion's share of crashes on libhwui.so@0x2fe72 signature are Pixel, Pixel 2 and Nexus 6P.
Crash Signature: [@ libGLESv2_adreno.so@0x309c2a] → [@ libGLESv2_adreno.so@0x309c2a] [@ libhwui.so@0x2fe72]
Trying an alternate ni to see if this can be reproduced.
Flags: needinfo?(ioana.chiorean)
I have been testing with a Nexus 6P running Android 8.1.0 and was still not able to reproduce a crash in any of the scenarios that I have tried, regardless of the fact that there were or weren't any addons installed. I will continue testing throughout the day and come back with further details if I find any relevant information or STR. NI-ing Ninu as well to look over this.
Flags: needinfo?(mihai.ninu)
(Reporter)

Comment 14

14 days ago
Could it have to do with the process being started through the URI handler? I'm frequently on Reddit and AFAIK, it could only happen when opening pages that way.
(Reporter)

Comment 15

14 days ago
To clarify, I use the app "Reddit is Fun"
tracking-fennec: --- → ?
tracking-fennec: ? → +
Priority: -- → P3

Comment 16

20 hours ago
(In reply to Marcia Knous [:marcia - needinfo? me] from comment #12)
> Trying an alternate ni to see if this can be reproduced.

Thanks Marcia, indeed the other mail is not used. 
I spend the last two days trying with different addons in and also with reddit. As Bogdan said I am not seeing any blockers. 
Device: Android 8.1.0 Pixel 2

Just to make sure, Landon - is the app still crashing for you now again if u used the handler like in reddit?
Flags: needinfo?(mihai.ninu)
Flags: needinfo?(landon)
Flags: needinfo?(ioana.chiorean)
Flags: needinfo?(ioana.bugs)
(Reporter)

Comment 18

15 hours ago
Ioana, I do not know if that's what causes the crashes. I just know that probably 95% of the websites I visit are from other apps.
Flags: needinfo?(landon)
You need to log in before you can comment on or make changes to this bug.