Closed Bug 1433834 Opened 4 years ago Closed 4 years ago

GestureSupport error

Categories

(Core :: Panning and Zooming, defect)

60 Branch
x86_64
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 688990

People

(Reporter: amit2rockpower, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.132 Safari/537.36

Steps to reproduce:

i wanted to zoom in /out with gesture control using trackpad of  (Macintosh; Intel Mac OS X 10.13; rv:60.0) Gecko/20100101 Firefox/60.0


Actual results:

it is not recognizing the gesture to get zoom in or zoom out. 


Expected results:

like if two touches on the trackpad are moved closer , webpage should be zoom out and else if moved farther the webpage should be zoom in.
in terminal i'm getting this message
*JavaScript error: chrome://browser/content/browser-gestureSupport.js, line 468: TypeError: window.content is null* 
*JavaScript error: chrome://browser/content/browser-gestureSupport.js, line 449: TypeError: window.content is null*
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86_64
Kamit, does the same also happen in older versions of Firefox like 59, 58, or 57? Otherwise I don't know if that is a feature we support. Moving into the right component for now.
Component: Untriaged → Panning and Zooming
Product: Firefox → Core
Zooming via trackpad on OS X is not implemented, duping this to bug 688990.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: desktop-zoom-mac
You need to log in before you can comment on or make changes to this bug.