Closed Bug 1434447 Opened 2 years ago Closed 2 years ago

Update HarfBuzz to 1.7.5

Categories

(Core :: Graphics: Text, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla60
Tracking Status
firefox60 --- fixed

People

(Reporter: RyanVM, Assigned: RyanVM)

References

Details

Attachments

(1 file)

Overview of changes leading to 1.7.5
Tuesday, January 30, 2018
====================================

- Separate Khmer shaper from Indic.
- First stab at AAT morx. Not hooked up.
- Misc bug fixes.

Seems like there's been a lot of churn since 1.7.4. I'm inclined to wait a bit to see if any issues crop up elsewhere before taking it. Anyway, I can cook up the patch in the mean time.
Bah, unified build bustage right out of the gate.
https://treeherder.mozilla.org/logviewer.html#?job_id=159425178&repo=try
Putting hb-ot-shape-complex-khmer.cc into SOURCES instead of UNIFIED_SOURCES fixes the build bustage. Tests are looking green.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=4679afa1bff6acc5aff7d358bcb40703989a61e4
Assignee: nobody → ryanvm
Gecko 60 is going to Beta on Thursday, 1-March. Should I go ahead and land this ahead of that?
Flags: needinfo?(ryanvm)
Flags: needinfo?(ryanvm) → needinfo?(jfkthame)
Gecko 60 is destined to be the next ESR, isn't it? Yes, I think we should go ahead and take the update in preparation for that, rather than leaving it with an older version.
Flags: needinfo?(jfkthame)
Attachment #8954424 - Flags: review?(jfkthame)
Comment on attachment 8954424 [details] [diff] [review]
update harfbuzz to version 1.7.5

Review of attachment 8954424 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM, thanks.
Attachment #8954424 - Flags: review?(jfkthame) → review+
https://hg.mozilla.org/mozilla-central/rev/9e8a6aa4f36b
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Blocks: 1443812
Duplicate of this bug: 1347672
You need to log in before you can comment on or make changes to this bug.