Closed Bug 1434503 Opened 2 years ago Closed Last year

regression: flickering black line above and below videos when scrolling on twitter

Categories

(Core :: Graphics: WebRender, defect, P2)

x86_64
All
defect

Tracking

()

RESOLVED FIXED
mozilla64
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- disabled
firefox58 --- unaffected
firefox59 --- unaffected
firefox60 --- disabled
firefox61 --- disabled
firefox62 --- disabled
firefox63 --- disabled
firefox64 --- fixed

People

(Reporter: darkspirit, Assigned: cpearce)

References

(Blocks 2 open bugs, )

Details

(Keywords: correctness, nightly-community, regression)

Attachments

(3 files)

Attached video 2018-01-31_02-33-56.mp4
Nightly 60 x64 20180130223236 de_DE @ Debian Testing (KDE, Radeon RX480)
fresh profile: gfx.webrender.all

Only happens with WR.
mozregression --good 2017-10-01 --bad 2018-01-30 --pref layers.acceleration.force-enabled:true gfx.webrender.enabled:true gfx.webrendest.enabled:true gfx.webrender.blob-images:true image.mem.shared:true layout.display-list.retain:false general.autoScroll:true startup.homepage_welcome_url:"https://twitter.com/FirefoxNightly/media"
> 17:03.65 INFO: Last good revision: 65fe9a60d39dc8ddfdf805a3ffc8a217da638cab
> 17:03.65 INFO: First bad revision: 882e0b30bc0eaed2d78bee279e51b67e6ee6bbbf
> 17:03.65 INFO: Pushlog:
> https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=65fe9a60d39dc8ddfdf805a3ffc8a217da638cab&tochange=882e0b30bc0eaed2d78bee279e51b67e6ee6bbbf

> 882e0b30bc0e	Kartikaya Gupta — Bug 1408461 - Update reftest results and regenerate bindings for changes in WR PR 1841. r=jrmuizel
> b3d8a0eb09e6	Kartikaya Gupta — Bug 1408461 - Update reftest results for changes in WR PR 1868. r=Gankro
> d1a2ea63196c	Kartikaya Gupta — Bug 1408461 - Update reftest results for changes in WR PR 1869. r=jrmuizel
> d9818c8042f4	Kartikaya Gupta — Bug 1408461 - Update reftest results for changes in WR PR 1873. r=Gankro
> cd0e3778a5ba	Nicolas Silva — Bug 1408461 - Update reftest results for changes in WR PR 1822. r=kats
> c654a712755b	Kartikaya Gupta — Bug 1408461 - Update Cargo lockfiles and re-vendor rust dependencies. r=jrmuizel
> dd8eb671df75	Kartikaya Gupta — Bug 1408461 - Update webrender to commit 7892f5364bc4d35c7a9b42949f0ace4cc54f8b3c. r=jrmuizel

Try builds are gone.
Blocks: 1408461
Has Regression Range: --- → yes
Keywords: regression
Summary: flickering black line above and below videos when scrolling on twitter → regression: flickering black line above and below videos when scrolling on twitter
OS: Linux → All
See Also: → 1451439
I don't see this on Windows do you?
Flags: needinfo?(jan)
Depends on: 1451439
Attached video 2018-09-05 02-34-52.mp4
Yes.
Flags: needinfo?(jan)
The flickering above videos scrolling by on the twitter feed is caused by us not pixel snapping the bounds passed in for video frames' images, in AsyncImagePipelineManager::ApplyAsyncImageForPipeline().
Assignee: nobody → cpearce
When scrolling on Twitter video frames can sometimes be drawn with a flicker
above or below them. This is because the bounds for video frames' images that
we pass to WebRender are not rounded to pixel boundaries, and so they can end
up being rounded off in WebRender unexpectedly when composited.

So round off the bounds of video frame images to device pixel boundaries before
passing to WebRender.
Comment on attachment 9011973 [details]
Bug 1434503 - Round video frame images bounds to device pixel boundaries before passing to WebRender. r?sotaro

Sotaro Ikeda [:sotaro] has approved the revision.
Attachment #9011973 - Flags: review+
Pushed by cpearce@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/db833c936040
Round video frame images bounds to device pixel boundaries before passing to WebRender. r=sotaro
https://hg.mozilla.org/mozilla-central/rev/db833c936040
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
You need to log in before you can comment on or make changes to this bug.