Browser freezes when loading a flash webpage

VERIFIED DUPLICATE of bug 58339

Status

()

Core
Plug-ins
--
critical
VERIFIED DUPLICATE of bug 58339
16 years ago
16 years ago

People

(Reporter: Paulius, Assigned: serge (gone))

Tracking

({hang})

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [flash], URL)

(Reporter)

Description

16 years ago
I have installed correctly flash and when I load a flash webpage the browser
freezes. I have the latest mozilla build...

Comment 1

16 years ago
Is /dev/dsp open when this happens? (In use by xmms or other sound apps..)
Likely dup of bug 58339. (Various workarounds mentioned there and in dups)

Updated

16 years ago
Severity: normal → critical
Keywords: hang

Comment 2

16 years ago
pls chek paulius.
(Reporter)

Comment 3

16 years ago
no I only run netscape only nothing in the backround... And nothing
opens when this bug ocurs the "M" animation freezes and I'm not able to
close the browser.Closes only with KDE System guard.

Comment 4

16 years ago
Paulis: what version of flash do you have installed? and what is the path? and
what verison of netscape do you have installed?
Assignee: beppe → serge

Comment 5

16 years ago
There are two other known issue where flash fails on Linux; some Debian
distributions, because they moved the esd lock file out of the temp dir, so
flash can't find it. And then the "crash when running on remote display" bug,
but that's irrelevant here.

The kde sound daemon can cause the same hang. So can the es1371 sound driver.
Please check that /dev/dsp is in fact NOT in use when this occures.
(lsof /dev/dsp). As a workaround you can try to start mozilla with
"artsdsp mozilla" (without quotes) and see if that improve things.
I'm pretty sure this is a duplicate. I still have never seen it since i use the
driver for a SB card and the esd sound deamon. I browse flash sites daily, with
daily builds.

Comment 6

16 years ago
Reporter mailed:

"I have a sound blaster live card witch for some reasons dosent work on
my SOT Linux 2002. I have a 400mhz celeron and a NVidia geforce2 mx400
64mb video card... I hope that these infos will be useful!"

--

Reporter: If you start mozilla with "artdsp mozilla" - does the hang still occure?
I believe this hang can be caused by the KDE sound deamon kepitn /dev/dsp busy
for for instance system sounds. Whether your sound-card is configured correct or
not doesn't necessarily have anything to do with this - the device can still be
busy.
(Reporter)

Comment 7

16 years ago
I'm sorry but I'm not able to access my linux computer for one month... But 
after that I will test it... And I'm not an expert with the console!

Updated

16 years ago
Whiteboard: [flash]

Comment 8

16 years ago
Shrir: can you check this one out on linux -- if it works for you, can you
please mark the bug as wfm, thanks

Comment 9

16 years ago
yeah wfm on 0521 branch build , redhat 7.1
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 10

16 years ago
v
Status: RESOLVED → VERIFIED
(Reporter)

Comment 11

16 years ago
Look guys... I really got to have flash on mozilla because netscape setup dosent
work on my computer... Sound and viseo runs perfectly on game but flash freezes
INSTANTLY when loading a flash website. The modem still loads the page but the
brozer is frozen and the only way how to close it is to close with the KDE
System Guard.
Status: VERIFIED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Assignee)

Comment 12

16 years ago
this is linux flash plugin 5 r4x problem bug 58339,
did you read comment #5 From R.K.A?
the are several workaround mentioned in that big report,
one of its use old flash 4 plugin, you can find *.so file in attachment
of bug 58339

*** This bug has been marked as a duplicate of 58339 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 13

16 years ago
Yeah but I got a sound blaster live! sound card (emu10k)

Comment 14

16 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.