Crash in core::result::unwrap_failed<T> | webrender::render_backend::RenderBackend::save_capture

RESOLVED DUPLICATE of bug 1433932

Status

()

Core
Graphics: WebRender
--
critical
RESOLVED DUPLICATE of bug 1433932
23 days ago
23 days ago

People

(Reporter: calixte, Unassigned)

Tracking

(Blocks: 1 bug, {crash, regression})

Trunk
Unspecified
Windows 10
crash, regression
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox58 unaffected, firefox59 unaffected, firefox60 affected)

Details

(crash signature)

(Reporter)

Description

23 days ago
This bug was filed from the Socorro interface and is
report bp-d31d2092-1c0c-4d97-a682-875990180131.
=============================================================

Top 10 frames of crashing thread:

0 xul.dll std::panicking::rust_panic_with_hook src/libstd/panicking.rs:583
1 xul.dll std::panicking::begin_panic<alloc::string::String> src/libstd/panicking.rs:538
2 xul.dll std::panicking::begin_panic_fmt src/libstd/panicking.rs:522
3 xul.dll core::panicking::panic_fmt src/libcore/panicking.rs:71
4 xul.dll core::result::unwrap_failed<std::io::error::Error> src/libcore/macros.rs:23
5 xul.dll webrender::render_backend::RenderBackend::save_capture gfx/webrender/src/render_backend.rs:924
6  @0x7ff67feadf 
7 xul.dll webrender::render_backend::RenderBackend::run gfx/webrender/src/render_backend.rs:588
8 xul.dll std::sys_common::backtrace::__rust_begin_short_backtrace<closure, > src/libstd/sys_common/backtrace.rs:133
9 xul.dll alloc::boxed::{{impl}}::call_box<, closure> src/liballoc/boxed.rs:762

=============================================================

There are 2 crashes (from 1 installation) in nightly 60 with buildid 20180131100706. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1433567.

[1] https://hg.mozilla.org/mozilla-central/rev?node=0c95a19decb5
Flags: needinfo?(bugmail)
No longer blocks: 1433567
Status: NEW → RESOLVED
Last Resolved: 23 days ago
Flags: needinfo?(bugmail)
Resolution: --- → DUPLICATE
Duplicate of bug: 1433932
You need to log in before you can comment on or make changes to this bug.