Closed Bug 1434664 Opened 2 years ago Closed 2 years ago

[mozdevice] Should use posixpath.normpath for determining remote pathnames

Categories

(Testing :: Mozbase, enhancement, P1)

enhancement

Tracking

(firefox60 fixed)

RESOLVED FIXED
mozilla60
Tracking Status
firefox60 --- fixed

People

(Reporter: wlach, Assigned: wlach)

References

Details

Attachments

(2 files)

Based on the log in https://bugzilla.mozilla.org/show_bug.cgi?id=1431403#c16, I think mozdevice's push/pull methods are not working on Windows. Using sys.path.normpath will turn a pathname into a Windows pathname, which is not what we want here.

Historically we have not supported Windows in mozdevice. I don't particularly care about changing that assumption, but I'd like mozregression to work for Android bisection so think we should patch this up, especially since it's little work. Hopefully it's the only issue...
Priority: -- → P1
Woohoo, I verified that the change fixes mozregression on Windows (bug 1431403). On to bc to review...
Comment on attachment 8947169 [details]
Bug 1434664 - Fix mozdevice's pull/push methods on Windows

https://reviewboard.mozilla.org/r/216942/#review223410

Nice. r+
Attachment #8947169 - Flags: review?(bob) → review+
Comment on attachment 8947938 [details]
Bug 1434664 - Bump mozdevice to 0.52

https://reviewboard.mozilla.org/r/217616/#review223412

r+
Attachment #8947938 - Flags: review?(bob) → review+
Do we want to go ahead and do devicemanagerADB.py as well? There are a couple of os.path.normpath calls in there, but if it is never used on Windows it doesn't really matter. Thanks!
(In reply to Bob Clary [:bc:] from comment #7)
> Do we want to go ahead and do devicemanagerADB.py as well? There are a
> couple of os.path.normpath calls in there, but if it is never used on
> Windows it doesn't really matter. Thanks!

Yeah, the only motivation for using devicemanagerADB on Windows would be to run mochitest/reftest for android on that platform, and I'm sure there's a pile of other reasons that won't work right now. Let's just skip it and do the minimal thing here.
Pushed by wlachance@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/82b26c23e07b
Fix mozdevice's pull/push methods on Windows r=bc
https://hg.mozilla.org/integration/autoland/rev/8b359f41473b
Bump mozdevice to 0.52 r=bc
https://hg.mozilla.org/mozilla-central/rev/82b26c23e07b
https://hg.mozilla.org/mozilla-central/rev/8b359f41473b
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Duplicate of this bug: 1367197
You need to log in before you can comment on or make changes to this bug.