[PP]regression-backspace doesn't work

VERIFIED FIXED in M11

Status

MailNews Core
Composition
P3
critical
VERIFIED FIXED
18 years ago
9 years ago

People

(Reporter: esther, Assigned: Akkana Peck)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Using 19990920 build on linux, backspacing in New Msg window doesn't work.  I
have to select the text then hit backspace button to remove the text from the
field.   When I do that and then send, I get boxes where the backspaces were
tried.  An example of a header from this scenario:

In the Inbox of 4.x I see the subject as:
"bb|||back space not working"
It should be:
 "backspace not working"
In the message header I see: a square before esther@netscape.com and then 3 more
squares.

This happens in the subject and the body too.  Can't check Mac yet, it's not
working for me, Windows is OK.   This is extremely annoying when composing
messages

Updated

18 years ago
Assignee: ducarroz → buster
Summary: [PP]regression-backspace doesn't work → [PP]regression-backspace doesn't work
Seems to be an editor problem, reassign to buster

Updated

18 years ago
Blocks: 11091

Comment 2

18 years ago
I think this is happening on all Linux dialogs where there are text fields.
Fenella was seeing this also.  This may not pertain just to the editor.

cpratt - have you seen this on the browser side?

Comment 3

18 years ago
Pls ignore my previous comment.  I was thinking of some other bug.

Updated

18 years ago
Assignee: buster → akkana
Target Milestone: M11

Comment 4

18 years ago
reassign to akkana; set to M11.
Akkana--I am fixing a similar bug on Mac.  The editor code is explicitly checking
for charCode == 0 before checking for backspace keycode.  Can you check to see if
gtk is setting the charcode to 0? (that was the problem on Mac)

Comment 5

18 years ago
cpratt sez he's seen this before & that it's likely a dupe of another bug filed
by phillip.
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

18 years ago
Fixed yesterday.  Part of the continuing key event spec war.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 7

18 years ago
Linux (1999-10-13-08 m11) commercial
Win32 (1999-10-13-09 m11) commercial
Mac (1999-10-13-08 m11) commercial
This problem has been fixed. It was a Linux bug. But I checked all platforms
anyway
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.