Closed Bug 1434761 Opened 2 years ago Closed 2 years ago

Fix preprocessor check for release builds

Categories

(Toolkit :: Form Autofill, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla60
Tracking Status
firefox-esr52 --- unaffected
firefox58 --- unaffected
firefox59 + fixed
firefox60 --- fixed

People

(Reporter: past, Assigned: past)

References

Details

(Keywords: regression)

Attachments

(1 file)

The following check is wrong as it uses #ifdef instead of #if to evaluate an expression:

https://searchfox.org/mozilla-central/rev/c56f656febb1aa58c72b218699e24a76425bd284/browser/app/profile/firefox.js#1736

// Comma separated list of countries Form Autofill supports
#ifdef MOZ_UPDATE_CHANNEL == release
Comment on attachment 8947267 [details]
Bug 1434761 - Fix preprocessor check for release builds.

https://reviewboard.mozilla.org/r/217014/#review222860

Please uplift, since bug 1419312 landed wrong in 59.
Attachment #8947267 - Flags: review?(mh+mozilla) → review+
Pushed by pastithas@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c9c4506e6300
Fix preprocessor check for release builds. r=glandium
Flags: needinfo?(past)
https://hg.mozilla.org/mozilla-central/rev/c9c4506e6300
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Comment on attachment 8947267 [details]
Bug 1434761 - Fix preprocessor check for release builds.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1419312 
[User impact if declined]: the wrong set of countries will have form autofill enabled
[Is this code covered by automated tests?]: no, but this is about build system code, not Firefox code
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: not really
[Why is the change risky/not risky?]:
[String changes made/needed]:
Flags: needinfo?(past)
Attachment #8947267 - Flags: approval-mozilla-beta?
Oops, due to a rendering bug I missed the last couple of questions!

> [Why is the change risky/not risky?]: it involves build configuration code
> [String changes made/needed]: none
Sounds like a recent regression for 59, marking this bug accordingly.
Comment on attachment 8947267 [details]
Bug 1434761 - Fix preprocessor check for release builds.

Fixing the if statement for location check, we definitely need this for 59. Should be fixed in beta 7.
Attachment #8947267 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.