Closed Bug 1434801 Opened 3 years ago Closed 3 years ago

regression: Improper rendering of filter:drop-shadow() when using WebRender

Categories

(Core :: Graphics: WebRender, defect, P1)

Unspecified
All
defect

Tracking

()

RESOLVED FIXED
mozilla61
Tracking Status
firefox-esr52 --- unaffected
firefox58 --- unaffected
firefox59 --- unaffected
firefox60 --- disabled
firefox61 --- disabled

People

(Reporter: emmybaylove, Assigned: gw)

References

(Blocks 1 open bug)

Details

(Keywords: correctness, nightly-community, regression)

Attachments

(2 files)

Attached file test.html
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180131220303

Steps to reproduce:

– Open any page that makes use of filter:drop-shadow( ... )
– Note the affected element(s)


Actual results:

– The shadow is displayed in the wrong position regardless of the values specified in drop-shadow( ... )
– The bottom of the image is cut off
– Scrolling causes more undesirable effects


Expected results:

Ideally, the shadow would display as specified in the filter.
Component: Untriaged → Graphics: WebRender
Product: Firefox → Core
Thank you!
Confirmed in Nightly 60 x64 20180131220303 de_DE @ Debian Testing (KDE, Radeon RX480).
fresh profile: gfx.webrender.all

If I install https://addons.mozilla.org/en-US/firefox/addon/quantum-lights-dynamic/ and open at least another tab, something can get drawn on tabs. (Reminds me a bit of bug 1431575 and bug 1433839.)
Status: UNCONFIRMED → NEW
Has STR: --- → yes
Ever confirmed: true
OS: Unspecified → All
Version: 60 Branch → Trunk
mozregression --good 2018-01-01 --bad 2018-01-31 --pref layers.acceleration.force-enabled:true gfx.webrender.enabled:true gfx.webrendest.enabled:true gfx.webrender.layers-free:true gfx.webrender.blob-images:true image.mem.shared:true layout.display-list.retain:false startup.homepage_welcome_url:"https://bugzilla.mozilla.org/attachment.cgi?id=8947337|https://addons.mozilla.org/en-US/firefox/addon/quantum-lights-dynamic/"
> 12:54.15 INFO: Last good revision: 5f6417128acb05b280c3c59a611e605458214dfd
> 12:54.15 INFO: First bad revision: 4d8fbb071d0ef1951b05873bf6dfb797645c2a99
> 12:54.15 INFO: Pushlog:
> https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=5f6417128acb05b280c3c59a611e605458214dfd&tochange=4d8fbb071d0ef1951b05873bf6dfb797645c2a99

> 4d8fbb071d0e	Kartikaya Gupta — Bug 1428766 - Update for changes in WR PR 2243. r=jrmuizel
> c31d02201979	Kartikaya Gupta — Bug 1428766 - Update webrender to commit 722e8b104bf99d29d61ecb1fe456eebe89ad81fd. r=jrmuizel

It has one other regression so far: bug 1432685

-----

(first good revision from above)
mozregression --repo autoland --launch 5f6417128acb05b280c3c59a611e605458214dfd --pref layers.acceleration.force-enabled:true gfx.webrender.enabled:true gfx.webrendest.enabled:true gfx.webrender.layers-free:true gfx.webrender.blob-images:true image.mem.shared:true layout.display-list.retain:false startup.homepage_welcome_url:"https://bugzilla.mozilla.org/attachment.cgi?id=8947337|https://addons.mozilla.org/en-US/firefox/addon/quantum-lights-dynamic/"
-> seems to be completely good

-----

> WR @ 007c61df33081caec1163db17305ccc191da7d99
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=5a44a6b13d4b59d4ecfa5e5a2452dd1d3248cee9
mozregression --repo try --launch 5a44a6b13d4b59d4ecfa5e5a2452dd1d3248cee9 --pref layers.acceleration.force-enabled:true gfx.webrender.enabled:true gfx.webrendest.enabled:true gfx.webrender.layers-free:true gfx.webrender.blob-images:true image.mem.shared:true layout.display-list.retain:false startup.homepage_welcome_url:"https://bugzilla.mozilla.org/attachment.cgi?id=8947337|https://addons.mozilla.org/en-US/firefox/addon/quantum-lights-dynamic/"
-> relatively good (tab title lights up briefly when scrolling down)

> WR @ 2918b6082e44bfdda8097225d7f68db47940252d
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=e480c5861792bc559b9dae8a3ec7aee35f6eb0c2
mozregression --repo try --launch e480c5861792bc559b9dae8a3ec7aee35f6eb0c2 --pref layers.acceleration.force-enabled:true gfx.webrender.enabled:true gfx.webrendest.enabled:true gfx.webrender.layers-free:true gfx.webrender.blob-images:true image.mem.shared:true layout.display-list.retain:false startup.homepage_welcome_url:"https://bugzilla.mozilla.org/attachment.cgi?id=8947337|https://addons.mozilla.org/en-US/firefox/addon/quantum-lights-dynamic/"
-> relatively good (tab title lights up briefly when scrolling down)

> WR @ 68dcbc468cabe327a52ce36b6c04a84fde905357
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=5a97e205e912db596234fbcae75e0e8788e18c07
mozregression --repo try --launch 5a97e205e912db596234fbcae75e0e8788e18c07 --pref layers.acceleration.force-enabled:true gfx.webrender.enabled:true gfx.webrendest.enabled:true gfx.webrender.layers-free:true gfx.webrender.blob-images:true image.mem.shared:true layout.display-list.retain:false startup.homepage_welcome_url:"https://bugzilla.mozilla.org/attachment.cgi?id=8947337|https://addons.mozilla.org/en-US/firefox/addon/quantum-lights-dynamic/"
-> bad (cut off/black on the bottom, but nothing bad on the tab)

> WR @ 68dcbc468cabe327a52ce36b6c04a84fde905357
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=de594a978f9bf87af47d90c19e43a13d0eb037a6
mozregression --repo try --launch de594a978f9bf87af47d90c19e43a13d0eb037a6 --pref layers.acceleration.force-enabled:true gfx.webrender.enabled:true gfx.webrendest.enabled:true gfx.webrender.layers-free:true gfx.webrender.blob-images:true image.mem.shared:true layout.display-list.retain:false startup.homepage_welcome_url:"https://bugzilla.mozilla.org/attachment.cgi?id=8947337|https://addons.mozilla.org/en-US/firefox/addon/quantum-lights-dynamic/"
-> bad (cut off/black on the bottom, but nothing bad on the tab)

> WR @ a54e2c425d1965fc0028efe2418986cbbc3a04bc
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=e4544eb10bd7b9b598721110c25c6576480c972c
mozregression --repo try --launch e4544eb10bd7b9b598721110c25c6576480c972c --pref layers.acceleration.force-enabled:true gfx.webrender.enabled:true gfx.webrendest.enabled:true gfx.webrender.layers-free:true gfx.webrender.blob-images:true image.mem.shared:true layout.display-list.retain:false startup.homepage_welcome_url:"https://bugzilla.mozilla.org/attachment.cgi?id=8947337|https://addons.mozilla.org/en-US/firefox/addon/quantum-lights-dynamic/"
-> bad (cut off/black on the bottom, but nothing bad on the tab)

> WR @ a329965174578aeaf195271db75d7211bfb870b7
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=09f7f399781fd9274196b0510b4e7722d71100dd
mozregression --repo try --launch 09f7f399781fd9274196b0510b4e7722d71100dd --pref layers.acceleration.force-enabled:true gfx.webrender.enabled:true gfx.webrendest.enabled:true gfx.webrender.layers-free:true gfx.webrender.blob-images:true image.mem.shared:true layout.display-list.retain:false startup.homepage_welcome_url:"https://bugzilla.mozilla.org/attachment.cgi?id=8947337|https://addons.mozilla.org/en-US/firefox/addon/quantum-lights-dynamic/"
-> bad (cut off/black on the bottom, but nothing bad on the tab)

> WR @ 722e8b104bf99d29d61ecb1fe456eebe89ad81fd
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=6d0eb76eebd01199a7b852fda157181fd4562fa0
mozregression --repo try --launch 6d0eb76eebd01199a7b852fda157181fd4562fa0 --pref layers.acceleration.force-enabled:true gfx.webrender.enabled:true gfx.webrendest.enabled:true gfx.webrender.layers-free:true gfx.webrender.blob-images:true image.mem.shared:true layout.display-list.retain:false startup.homepage_welcome_url:"https://bugzilla.mozilla.org/attachment.cgi?id=8947337|https://addons.mozilla.org/en-US/firefox/addon/quantum-lights-dynamic/"
-> bad (cut off/black on the bottom, but nothing bad on the tab)

> WR @ 722e8b104bf99d29d61ecb1fe456eebe89ad81fd
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=e0af143b16a92c2eb2653a865edb69a9c0bed0fd
mozregression --repo try --launch e0af143b16a92c2eb2653a865edb69a9c0bed0fd --pref layers.acceleration.force-enabled:true gfx.webrender.enabled:true gfx.webrendest.enabled:true gfx.webrender.layers-free:true gfx.webrender.blob-images:true image.mem.shared:true layout.display-list.retain:false startup.homepage_welcome_url:"https://bugzilla.mozilla.org/attachment.cgi?id=8947337|https://addons.mozilla.org/en-US/firefox/addon/quantum-lights-dynamic/"
-> bad (cut off/black on the bottom, but nothing bad on the tab)

Why do I still have not seen the broken tab title?

> https://hg.mozilla.org/integration/autoland/rev/c31d02201979
> Update webrender to commit 722e8b104bf99d29d61ecb1fe456eebe89ad81fd. r=jrmuizel
mozregression --repo autoland --launch 4d8fbb071d0ef1951b05873bf6dfb797645c2a99 --pref layers.acceleration.force-enabled:true gfx.webrender.enabled:true gfx.webrendest.enabled:true gfx.webrender.layers-free:true gfx.webrender.blob-images:true image.mem.shared:true layout.display-list.retain:false startup.homepage_welcome_url:"https://bugzilla.mozilla.org/attachment.cgi?id=8947337|https://addons.mozilla.org/en-US/firefox/addon/quantum-lights-dynamic/"
-> bad (cut off/black on the bottom AND broken tab)

Autoland differs from try, even it's the same WR revision?!
Blocks: 1428766
Has Regression Range: --- → yes
Keywords: regression
Summary: Improper rendering of filter:drop-shadow() when using WebRender → regression: Improper rendering of filter:drop-shadow() when using WebRender
(In reply to Jan Andre Ikenmeyer [:darkspirit] from comment #3)
> > WR @ 2918b6082e44bfdda8097225d7f68db47940252d
> > https://treeherder.mozilla.org/#/jobs?repo=try&revision=e480c5861792bc559b9dae8a3ec7aee35f6eb0c2
> mozregression --repo try --launch e480c5861792bc559b9dae8a3ec7aee35f6eb0c2
> --pref layers.acceleration.force-enabled:true gfx.webrender.enabled:true
> gfx.webrendest.enabled:true gfx.webrender.layers-free:true
> gfx.webrender.blob-images:true image.mem.shared:true
> layout.display-list.retain:false
> startup.homepage_welcome_url:"https://bugzilla.mozilla.org/attachment.
> cgi?id=8947337|https://addons.mozilla.org/en-US/firefox/addon/quantum-lights-
> dynamic/"
> -> relatively good (tab title lights up briefly when scrolling down)
> 
> > WR @ 68dcbc468cabe327a52ce36b6c04a84fde905357
> > https://treeherder.mozilla.org/#/jobs?repo=try&revision=5a97e205e912db596234fbcae75e0e8788e18c07
> mozregression --repo try --launch 5a97e205e912db596234fbcae75e0e8788e18c07
> --pref layers.acceleration.force-enabled:true gfx.webrender.enabled:true
> gfx.webrendest.enabled:true gfx.webrender.layers-free:true
> gfx.webrender.blob-images:true image.mem.shared:true
> layout.display-list.retain:false
> startup.homepage_welcome_url:"https://bugzilla.mozilla.org/attachment.
> cgi?id=8947337|https://addons.mozilla.org/en-US/firefox/addon/quantum-lights-
> dynamic/"
> -> bad (cut off/black on the bottom, but nothing bad on the tab)

The range for this is:

* 68dcbc46 Auto merge of #2243 - mephisto41:drop-shadow-edge, r=kvark
* f0cf25ef Fix drop-shadow render incorrectly on viewport's edge.

Let's use this bug to track this regression. If there's other wonkiness going on we can file another bug for that.

> Autoland differs from try, even it's the same WR revision?!

It might be because they're based on different mozilla-central versions. The try build was based off e61c4485494e while the autoland was based off 5f6417128acb. This is the set of changes in between those two: https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=e61c4485494e&tochange=5f6417128acb - this includes bug 1429577 which might be relevant.
Assignee: nobody → gwatson
Priority: -- → P1
Duplicate of this bug: 1430789
Duplicate of this bug: 1447186
Duplicate of this bug: 1449370
This will be fixed when https://github.com/servo/webrender/pull/2588 lands in WR and Gecko.
Depends on: 1449562
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
You need to log in before you can comment on or make changes to this bug.