Crashes on "Manage Bookmark"

VERIFIED WORKSFORME

Status

--
critical
VERIFIED WORKSFORME
17 years ago
14 years ago

People

(Reporter: gds, Assigned: bugs)

Tracking

({crash})

Trunk
x86
Windows 2000
crash

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0+)
Gecko/20020503
BuildID:    2002050308

Wanted to add a bookmarked site to the Personal Toolbar. Opened Manage
Bookmarks. Tried to "drag" the bookmarked url into the Personal Toolbar folder
and somehow the Personal Toolbar folder disappeared. It no longer showed up the
Manage Bookmarks dialog (it was at the top).  Closed down Manage Bookmarks and
started it again. This time it crashed mozilla and I sent the crash feedback
report (full-circle). 

The above was on win2k. Tried similar thing on moz/linux but used cut/paste in
Manage Bookmark dialog and it worked as expected. 

Reproducible: Always
Steps to Reproduce:
1. Open "Manage Bookmarks"
2. Drag a personal bookmark to Personal Toolbar folder
3. Personal Toolbar folder went away (separator line at top)
4. Shutdown Manage Bookmarks, and restart mozilla (I think)
5. Open Manage Bookmarks
6. Crash
7. Reinstall moz to fix?

Actual Results:  Crash on Manage Bookmark

Expected Results:  Not crash. Personal Toolbar folder should still exist.

Comment 1

17 years ago
Could you provide TalkBack incident ID?
URL: n/a
Severity: normal → critical
Keywords: crash
this is not happening to me with build 2002050807 on WinXP

bye
Francesco De Francesco
(Reporter)

Comment 3

17 years ago
The things that pops up after the crash is "Netscape Quality Feedback Agent --
Mozilla Trunk". I don't see a incident ID in the dialog. I did enter my email
address( gds@chartertn.net ) and problem description into it before sending. 

Tried using the bookmark.html file from linux box. Still crashed on "Manage
Bookmarks".  Also just deleted bookmark.html and got same result. 

Maybe I will reinstall and try this again.
(Reporter)

Comment 4

17 years ago
More info: Moved all the application files to recycle bin. Put them back one at
a time. The culprit seems to be XUL.mfl. When I just remove this file (and let
the system recreate a new one) I have no problem. When I restore the possibly
corrupted file I get the crash on Manage Bookmarks.  

However, I am unable to duplicate the original problem when using the
regenerated XUL.mfl. Will try some more.

Comment 5

17 years ago
Could you attach the file you think is corrupted? If it really is, it should
cause a crash for anyone when it is used. Odds are, however, that this crash is
not the fault of Mozilla, but of a corrupted file, which Mozilla cannot read
properly. If that is the case, then this bug really indicates that this is an
error that is not bveing handled properly, as a crash is not an really
acceptable response to any condition.
(Reporter)

Comment 6

17 years ago
Ok, but "bad" XUL.mfl is on computer at work. I will attach/send it Monday. Also, I tried everything but could never get it to mess-up again. Maybe it was just a random corruption due to the o/s (win2k) or something.-gene
(Reporter)

Comment 7

17 years ago
Created attachment 83332 [details]
File crashes mozilla on "Manage Bookmarks"

The file XUL.mfl (pkzipped to XUL.zip) somehow got corrupted and now crashes
mozilla when I do Bookmarks->Manage Bookmarks.

Comment 8

16 years ago
still reproducible using latest build with a NEW profile?

Comment 9

16 years ago
is the crash still happening using mozilla 1.0 and a NEW profile?
if so, please provide the talkback crash ID.
(you can get this from running talkback.exe, found under components/ dir.)

your reply is requested, otherwise this bug will be marked as WorksForMe.

Thanks for testing mozilla!
(Reporter)

Comment 10

16 years ago
No problems seen with Moz 1.0 and New Profile using the suspect XUL file. 
-reporter

Comment 11

16 years ago
Resolving as WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 12

16 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.